QC won't boot, keeps blue lights flashing

My QC just won’t boot, there’s nothing appearing on screen although it has its buttons flashing a blue light. I haven’t had any power or connection issues before this occurs and the last thing I did was synchronise some presets and captures from cloud, turn of (on the power button) and later turn the QC on again.

I’ve just contacted the support but maybe it’s something people here already seen and have a solution.

Hope someone can help the easy way :smiling_face_with_tear:

Thanks in advance

I have the same problem today.
Unable to start my QC.

Obviously when my band was reunited to record the first song of our new album: man_facepalming:

Fortunately, NDSP plugins were to the rescue :smiley:

These things always happens when we need them the most.

Did you find any solutions for the QC problem?

Hi,

I haven’t any solution for now, and you ?

Nothing here too. Sent QC to Neural, but it looks like some OS error (or hardware correlated to it).

Some guys on Reddit said that reconnecting a SD Card that is found inside the QC solved the issue, but haven’t tried it, preferred to reach Neural support.

Hope they solve and find the cause of the error.

For these issues during booting up, most have resolved by removing everything (e.g. USB, XLR, TS/TRS etc.) and then try rebooting.

Unfortunately I’ve tried this, but didn’t work :smiling_face_with_tear:

I’ve seen 2 users in our community WhatsApp group with the same problems , blinking footswitch with blank screen . They open the back panel and re insert the memory card . And the unit live again

2 Likes

I wouldn’t recommend doing anything that could void the warranty IMO.

So true , hope I’m not facing this kind of problems . Opening the unit itself is horrible moment , I hope QC known this bug and fixed it for good

Okay…so “F@CK!”
I was downloading a Preset I had just saved on the QC app, and then it quickly flashed an “Error” message that flashed for a second, crashed, and now it won’t reboot and I’ve got the flashing blue lights and the blank screen. I’ve tried rebooting 20 times…nothing…
Any word at all from anyone at Neural about this? I’m really hoping I don’t have to send it in. I have shows in the next 3 weeks.

Remove anything connected/plugged in, power cycle then re-try to boot.
Worst case, email support@neuraldsp.com and they will take care of you.

Yep. Did that. Thank you though.

I’ve had the same problem for a month.

Just had that happen to me. Fired up the QC, while switching presets I saw one was blank for some reason, decided to reboot via to power button, clicked the reboot button on screen… won’t boot, flashing blue LEDs.

Tried unplugging everything. Will not open the back. Hopefully Thomann can just send me a replacement.

Was supposed to start a new project rehearsals this week… :rage:

Same problem here, it’s unbelievable face a problem like that for a 2K USD product…