Quad Cortex will not boot

I have a quad cortex thatvwill no longer start/boot

When powering up, the foot switches flash five times and then nothing. The screen stays blank.

Every 15 seconds there will be a very brief flash on the screen like it is trying to do something .

I have tried to restart multiple time with always the same result.

I have not recently tried to update firmware etc

hi baggio, try this:

Hi, thanks for the response. I did try that yesterday but unfortunately the screen is not displaying anything so cannot use that solution.

Tried again this morning and cortex booted up as normal. I restarted and it is back to the same where lights flash 5 times and screen does nothing.

have you tried booting up with nothing else connected- only the power supply?

Thanks, yes only got the power supply connected and nothing else. Also tried moving to other sockets but same response.

Are you unplugging everything and using the OEM power supply? If not OEM, ensure the PS is providing 12v @ at least 2A (preferably 3A). Lastly, try the factory reset if possible and email support@neuraldsp.com.

I am using factory power supply. Unfortunately I cannot do factory reset as screen is not displaying anything.

I have emailed support but also posted here to see if anybody has had similar issue.

As stated earlier, it did boot up once this morning before going back to non response.

Just to provide an update, I managed to get the unit to boot up after hours of trying.

I immediately updated the firmware to the latest version and for now that appears to have fixed it.

1 Like

Spoke to soon - back to same problem. So frustrating.

my unit did this this weekend, i shrugged it off and re-powered it and it came up fine.

now you have me scared af

So it was working again and booted up but now in the same previous state? What occurred from the time you resolved the boot issue to current?

Nothing happened apart from turning it off and starting it up again and it went back to a non- responsive state.

I managed to get it working again late last night and appeared to start working this morning.

At the moment I am not overly confident that it will start

Understood, something is definitely amiss, please email support so that they can log the issue and provide resolution etc.

I have messaged support and it has been agreed that I will monitor the situation but if not it will need to go in for a look.

Hi Baggio, Try this

I had the same problem
worked for me !!

Just be careful of potentially voiding your warranty. It’s always best to email support so that they can log the issue and provide resolution.

yes, I sent it, if the problem persisted, I would send the QC to them, but I’m in Brazil, it´s very hard send the QC.
We still don’t have support here.


Just to provide an update. The Quad Cortex has been working fine the last 2 to 3 days without a repeat of the problem.

I wish I could say what I did to fix it but honestly I do not know. I think it was more a software problem rather than hardware.

At the moment, I am a bit - is it going to turn on this time?


My QC has just started doing this… at a gig on Sunday it didn’t start up, pulled the power IEC out of the DC7 then back in to power up again. It did start up as normal and was ok all gig. At the time, thought nothing of it but today it did the same thing…. I’ve emailed Neural, that asked my to send the report from the QC… waiting on a reply……

Just an update if anyone is interested.
I received this reply from customer support:

Hi Justin,

Thanks for the video and update. Nothing unusual from the report but i’ve forwarded you case also to the developers.

We’ve now had several instances of this issue reported and the developers are treating it as high priority. The cause is as yet unknown but it’s highly likely its an issue in the software, so any fix will hopefully be addressed in the next or future update.

Let me know if the issue continues, gets worse, or makes the unit unusable. Also if you have any questions or further issues please let us know as soon as possible.

Best Regards

Best regards,
Neural DSP Support Team

When I replied so your solution is, let us know if it gets worse? The response was:

HI Justin,

I wouldn’t paraphrase it like that. I said the developers are treating it as high priority. The cause is as yet unknown. Solutions are difficult to advise for as yet unknown root causes but we are on the case.

Thanks for your patience

Best regards,
Neural DSP Support Team

Pretty disappointed in Neural at this point… the product I purchased is faulting and no solution…