MIDI control only works in standalone, not DAW

I just bought this plugin today after my trial expired, and I’m loving it! I have an old BOSS GT-10 that I decided to use as a midi controller with the Plini plugin. When I run the standalone Plini program, I can program the midi map and switch presets successfully with the 6 pedals in my midi controller. I play live almost every week and wanted to try this out.

However, when I run Plini as a vst in my DAW, Studio One 4.6 (I’ve tested in Reaper and Fl Studio as well), the Plini plugin does not respond to any of my midi commands. I can’t change presets or do anything. As I mentioned, I know everything is setup correctly, because it works perfectly in the standalone version. I tried using a midi keyboard as well by assigning notes to change presets, and nothing happens in the Plini plugin.

I want the Plini plugin with full midi switch capabilities to work in my daw, so that I can add chorus, harmonizers, and other vst effects to my fx chain during live performance.

Is anyone else having the same issue? Any comments or help would be appreciated!

Hello @erik.morgan. Please check with the VST2 version. VST3 (as a format) can have trouble receiving MIDI messages.

Thanks for the response. I just tried the VST2 version as well, with the same results. Spent quite a few hours trying to figure it out. Does it work in a daw for anyone else? Tested it with my midi keyboard as well. Both work in standalone, but not vst :frowning:

Try the following:

  • Create a new project in Studio One.

  • Go to Studio One > Options > External Devices and make sure your MIDI controller shows up on the list. If it’s not there, add it as a new device. Try with your MIDI keyboard first to make sure everything works as expected.

  • Once the controller appears on the list, add a new audio track and insert the VST2 version of Archetype: Plini on it. If you open the Plug-In window, the controller should appear on the top right. If it’s not there, select it from the drop-down list:

    Plini new keyboard

  • Create a new instrument track. Set the input as your midi controller and the output as Archetype: Plini:

    midi track

  • Open the Plug-In window again and check if the MIDI learn function works as expected. Right-click over any parameter (for example Stand by/Active amp) and select “Enable MIDI Learn”. Press a note of your keyboard twice to assign the key to the parameter, right-click on the Plug-In and select “Disable MIDI Learn”. You should be able to toggle between on/off using the note of the keyboard. If it doesn’t work, try again but this time click on the parameter after selecting “Enable MIDI Learn”.

  • Now let’s assign some presets. Pick a preset from the menu and right-click over it to select “Enable MIDI Learn”. Press a note twice and disable MIDI Learn. If you did this correctly, a MIDI icon will appear next to the preset:

    MIDI preset result

  • Do the same with another preset to make sure everything works as expected. From here you can continue to assign notes to presets from the mappings window. Keep in mind that the number of the octave might not correspond to the actual octave of your keyboard.

1 Like

Thanks for the helpful guide with pictures, I was able to successfully switch Plini patches from my midi keyboard using this method!

However, my BOSS GT-10 (or any other midi controller) isn’t a midi “instrument”, so it does not show up in the midi instrument input list. My midi controller (boss gt-10) does show up in the external devices list and is able to send midi signal to studio one (midi monitor shows this).

Is there a way to configure studio one to work with midi controllers too?

This might work:

  • Create a new project. Go to Studio One > Options > External devices, press “Add…” and select “New Keyboard” from the top of the list.

  • On “Receive from” select your foot controller and check if it appears on “Send to”. If it shows up there, select it too. Press “Ok”.

  • Open your mixer (F3) and double click on the “New keyboard”, it should appear under external devices. Enable “MIDI Learn” and press every control of your foot controller. Now they should appear on the keyboard window. Disable MIDI Learn.

If everything went right, you should be able to select the new keyboard as an input on the MIDI track while being able to send messages from your MIDI controller through the device. There’s a video that shows something similar, you might find it useful: Mapping MIDI controller.

I did already try this method, and it does work for 2 out of 6 of my pedals. I can only switch presets using the 2 pedals that send CC messages. The other 4 pedals that send PC messages can’t switch anything. Once I use midi learn to map the controls, then nothing works at all. It only works when I don’t use midi learn.

I suppose I need to get a different midi controller that can send CC messages from all the pedals, or I could try a different daw for live performance. It doesn’t help that it’s fairly impossible to find any useful Studio One tutorials for midi pedals, they all just re-explain the basic setup :frowning:

Update:
Success at last!

So, it turns out that the VST2 version can’t receive PC midi messages, it can only receive note value and CC messages. I switched back to the VST3 format after an hour of mental pain, and it finally works perfectly like in the standalone! (The problem was mainly that I didn’t know how to configure studio one for midi control properly, nothing was wrong with the Plini vst3).

Big thanks to your detailed setup info and suggestions! Everything’s good now :smiley:

1 Like

Awesome! Glad it’s working now.

So the VST2 Version can’t receive PC messages but the VST3 can? That’s strange, it should be the other way around.

Thank you… I use studio one and bought a boss gt-100 as controller… now I just need the update for Nolly and hopefully this works the same way… thank you again

@heyjthirty3 You’re welcome! We’ve taken longer than usual with the update to fix some issues, but it will work the same way.

Can you please give instructions for Reaper? That’d be a great help please!!..

Hi @dimitris.mitrolios. Check if this works:

  • Open Reaper, go to Options > Preferences… > MIDI Devices and check that your device is recognized at MIDI inputs and MIDI outputs.

  • Double click on your device at MIDI inputs, check Enable input from this device and Enable input for control messages . Then double click on your device at MIDI outputs and check Enable output to this device . There’s a video that goes through this.

  • Create two tracks. Insert the VST2 version of Archetype: Plini on the first track. Then go to the second track and make it a sub-track of the first one by drag-and-drop or by clicking on the folder icon at the bottom-left corner of the track:

    reaper midi 1

  • Go to the second track and set the input as your MIDI device (Input MIDI > All MIDI inputs > All channels ). You can also make a send from the MIDI track to the Plini track.

  • Enable monitoring and check if the track receives an input signal when you send notes/PC/CC messages. It should get registered on both tracks:

    reaper midi 2

  • You can record some notes/PC messages to check if everything is routed correctly:

    reaper midi 3

  • After this, you just need to map your presets/parameters using the MIDI learn function or the MIDI mappings window. You can also use this method to automate preset changes through notes/PC messages.

I think there’s also another method using ReaControlMIDI. There are plenty of tutorials that show how to use it: ReaControlMIDI Plugin in REAPER

5 Likes

It worked!! Thanks man!

@flavinhaedalton No problem!