MIDI control of Nolly in Reaper using Behringer FCB1010

Praying someone can help me here. I’ve wasted so many hours trying to work this out its not even funny.

So I have a Behringer FCB1010 - using Standalone Nolly I can get it to change presets just fine.

Problem is when I try and use Nolly within Reaper. I do the MIDI mapping the same was as with the Standalone version. I know that Reaper is receiving signals from the FCB1010 as it shows the PC signals when I set the track to record.

I’ve followed the instructions in this thread: MIDI control only works in standalone, not DAW

But still not getting anywhere - the only version that is showing up in Reaper is the VST3 - that thread mentions VST2 but that doesn’t seem to exist on my system (running the latest update of Nolly).

Absolutely out of ideas now - if anyone has any idea how to get this working I’d be really grateful.

Thanks.

Hi @Methtical. Check if the VST2 is installed on the correct folder (C:/ Program Files / VSTPlugins /, if you’re on Windows). Then go to Reaper > Options > Preferences > VST, make sure that Reaper recognizes that folder, press Clear cache/re-scan, Apply/Ok and restart Reaper.

That should make it appear under the VST tag. If it still doesn’t show up after that, close Reaper, uninstall the Plug-In, and reinstall it with the exception of adding a subfolder containing it (example: C: \ Program Files \ VSTPlugins \ “Custom Folder Name” ).

Re-scan your Plug-Ins and check if the issue persists.

Thanks, that solved the issue, for some reason Reaper had neglected to scan all the relevant VST folders, even though it had before.

But sure enough using just the VST version of Nolly, it started responding to the FCB straight away.

I have quickly enocountered another issue though…

When I’m recording a track and use the FCB to switch presets, the output is responding accordingly (i.e going from a distortion effect to a clean), however when I playback the track, it seems this isn’t being recorded as such (its just continuing to playback distorted), despite it also showing the PC message being sent on the MIDI track.

How do I get it to record and playback the change in preset accurately?

Thanks,

Nevermind, problem solved. Thanks.

I was going to suggest that you could write on the MIDI region to automate preset changes. How did you fix it?

Changed the setting from Trim/Read to Write on the Nolly track - which Im guessing is the same thing as what you put. I’m completely new to the DAW game so not fluent with the lingo.

1 Like