USB audio from my Mac to QC does not sound right

Hello friends,
I have the USB audio cable plugged into my Mac. When I play Apple Music through to the QC and have my headphones plugged in it sounds terrible. It is making strange noises and sounds like a hollow version of what it should be. It also sounds lousy on speakers as well. So it is not my Headphones.

I was hoping to get a good sound through my Mac so that I could play along with music. Does anyone have any insights into what I may need to do? On the USB page I made sure it is not clipping and there does not appear to be much more that can be adjusted from there. Is there somewhere else in the unit that other adjustments can be made for a better sound? Thanks so much.

Note: I was observing the USB input while on the input page and noticed the USB input was intemittently blinking randomly. It seems to be a bad connection and it can be heard like a crackling sound through my headphones. I am also unable to get any volume to speak of and my headphones are not power hungry. Sennheiser 58X known to not need much power. Thanks.

Weird, is it by chance picking up a built in mic? Also, what are you monitoring with and how? Are the speakers plugged directly into the QC outs etc., and were you listening with headphones direct from QC or MAC? Guitar signals and QC sourced tones sound okay? I don’t know MAC that well so hopefully someone else will chime in. Worst case email and see if they can resolve.

1 Like

Thanks for your response. I have it in as simple setup as possible. The USB from my Mac to QC. A set of headphones plugged into the headphone jack on the QC. I just tried again and I notice my USB input (while I am on the input page) Is blinking on and off while trying to play music through the device. It is not clipping. In fact, even if it was working well the volume level is very low even turned all the way up. I just don’t get it.

What is the application playing the music on your Mac?
What input are you sending it to on the QC?

I use an aggregate device on my Mac, but I’ve switched a few things around to test.

Selecting the QC as Sound Input and Output Device in the Audio/Midi Setup window, and choosing USB inputs 5/6 on the QC, it’s working fine with my Senn HD 6Xxxs. I tried it with audio from Firefox browser and iTunes

1 Like

Hi Xush and thanks for responding. I am playing Apple Music and sending it to the USB. I have selected the QC as sound input and output. I am not sure about how to configure the inputs 5/6 you are referring to… maybe that is where I am missing the boat. Is that done on the same input page where the volume for the USB is located? I am playing Apple Music directly from the Apple Music App on my Mac. I have also tried YouTube to see if the problem is still there and it is. Thanks man.

USB 5/6 on one of the QC lanes, like you’re connecting an instrument (tap the Input Block and scroll down)

Is Apple Music the same as iTunes? (I guess it shouldn’t matter as long as you’re on a Mac- it should route the audio to the QC)

1 Like

When I tap on the Input 5/6 on the QC I get this message:

Manual route from the host to grid selectable lane input. Select output 5/6 from your host to route signal to the grid input.

On my Mac and in the Audio/Midi setup it does not let me choose this… It is grayed out and cannot be adjusted…

Huh, weird. What Mac are you using?
I’m on an iMac.

Was that from the Input Block on the far left at the beginning of a grid Lane, or the swipe down I/O menu? Use the Input Block, not the swipe-down

How were you routing the audio into the QC before?

I have not tried using it except for my guitar through input 1. I was trying to use the swipe down… When you say use the input block is it a global input block or the input block of whatever preset I happen to be on? This is confusing and I thank you again for your help. I am wanting to get music piped in and play my guitar out of input 1 at the same time. Is this possible? It seems like I can only choose one. Sorry for being so dense.

For a specific preset, See on the picture above where it says “In 1”?
Tap that (or any of the 4 Input blocks for the 4 separate lanes) and scroll down to the STEREO choices and tap USB 5/6. This changes the input source to the main QC grid. Do this on a separate Lane from your guitar input Lane. (I shouldn’t have picked Lane 1 for this example)

1 Like

I selected 5/6 on a separate line. When I do go to the swipe down screen it still shows it playing through inputs 1/2. I can hear music through it and then it starts making the weird noises and gets all garbled after about 15 seconds.

On the swipe down screen The USB Level is -32.8
HP Source is set to 1/2. There is no option for 5/6. Just 1/2 or 3/4, none or both.

When I put the USB 5/6 to a separate line is there anything I am supposed to add to that line?

Headphone setting shouldn’t matter, as you’re routing the USB signal to the grid just like guitar. Make sure the USB Lane on the grid has MULTI OUT selected at the other end.

1 Like

Yes I have it set on that already. I always use multi-out. Even if this did work I would have to do this to every preset that I wanted to use to play along with piped in music?

I don’t understand why it shows it coming through input 1/2 on the swipe down when I have selected 5/6. It still gives the error message about the Manual routing I shared earlier. I don’t want to take up too much of your time here.

Could it be something on my iMac that is causing the weirdness? Should I try another source? Like my DAP or something?

Sorry I’m not explaining this very well.
The garbled sound might be a sample rate mismatch (you select 48kHz in the Audio Midi menu of the Mac). Either that or Apple Music just doesn’t play nice with the QUAD

1 Like

Ah, the sample rate… the music I am playing is at a higher sample rate…but the YouTube music is not at a higher sample rate… grrrr

I’ll be out of the office for a while here- hopefully someone else who has more experience with this will chime in soon. I haven’t routed much INTO the QC because I use the aggregate setup with multiple interfaces. The only way I know to do it is per preset, but maybe someone will have experience with a more global approach. Sorry I couldn’t work it out!

1 Like

No need to apologize my man! It is not a life or death situation here! I need to remind myself of that… :wink: Have a great day and I wish you peace and well being in the midst of the hurdles of life. :slight_smile:

1 Like

can’t hurt to email NDSP support, they might see something we’re overlooking.
Have a good afternoon!

1 Like

Hi Xush, I wanted to thank you again for your time the other day and give you an update. I did contact support and they wanted me to essentially make a video of the situation and show the I/O board in picture form… I just am not up to doing all that. So I tried out two of my other MacBook Air’s on the unit and there was none of the noise or weirdness we were dealing with from my iMac desktop unit. The other two computers worked flawlessly without even changing any settings. Bottom line there is some kind of issue in the Desktop here. I have a solution: I will not use this desktop for an interface! Problem solved!

I was wanting to use the interface to play along with music from Apple Music with my guitar. It’s not that important to me to spend any more time than we already did on it. I found that if I use my earbuds connected to my DAP I can play the music and then with my headphones over the top of my earbuds I can play out of my QC and there it is. Problem solved. This desktop is quite a few years old. IF I really need to use the interface that way I can always get one of my laptops and use it.

Thanks again, and I do really appreciate you.

Glad to hear you found a way around it. I’m always happy to try to help, I was disappointed we couldn’t seem to find a solution.
There are SO many variables, I don’t know how NDSP manages to troubleshoot all the possibilities. Glad you found a way to do what you wanted!

1 Like