Horrible digital crackling and distortion over USB

For a long time I have been getting this absolutely HORRENDOUS digital sounding crackling when running my QC over USB. It doesn’t always happen, but it’s like 60% of the time. It also seems to delay the recording. I’m using Reaper and it will do this crackling sound and the Reaper interface will freeze up when it is recording or playing and this sound happens. I finally managed to capture a recording of it. That I’ll link or upload if I can figure out how to do that directly to this post.

Anyone else have this issue or know what it might be? It makes the QC completely unusable for doing any sort of USB recording, and the sound seems to come through the output of the QC but only over USB. When playing it with just my guitar and headphones or even live, this never happens, after many shows and practices. Unplugging and rebooting does not always work either. Sometimes it does, sometimes it doesn’t.

Uploaded this to my drive

I had seen this before. What computer and OS version are you running?

A few of us had problems on older Mac OS versions (10.14 and earlier). Since getting a new mac, and a uGreen USB B to C cable, I’ve not seen it happen…

Running Win11 Build 22621.

I seriously shouldn’t have to buy a new computer and cable to not have this be happening.

1 Like

have you searched previous threads concerning the USB recording issues with Windows/PC?
There’s a LOT of info out there for possible fixes/workarounds.
Here’s an older thread, you might find some helpful info in it:

1 Like

Ha, nah obviously my advice wasn’t “JuSt bY a £3k mAc EZPZ”

Definitely try another cable though. They’re like £8…

Also worth mentioning;

it’s essential to ensure that your DAW is set to 48kHz (which is what the QC uses) instead of 44. Any clock discrepancies between the DAW and interface can cause digital clicks and pops.

1 Like

Already ensured the settings are correct awhile ago, and tried a new USB cable. No luck. It does this like 60-70% of the time, renders the device completely unusable for recording or playing over USB.

Been in touch with customer support as well and none of their suggestions or requests have worked.

Have you looked in diagnostics and see which thing it is that’s going haywire?

Ensure you are using the most current USB drivers available as they were updated when the CoreOS 2.1 was recently released.

I am. Already checked that, the sampling rate, the DAW settings, everything.

Did you try the safe mode on the ASIO control panel? There are a ton of variables for USB audio related noises/interference. Do you hear the interference via headphones (and or all outputs?) as well? Lastly, have you tried to backup / factory reset and restore the QC?

Tried safe mode. Tried backup and reset.

Distortion only comes over my headphones and ONLY when using the QC over USB, but the distortion is in the signal chain since I am able to record it.

Sorry that you continue to experience these issues. Have you temporarily tried using another laptop/PC to see if the same behavior is exhibited? Otherwise, your only recourse is to continue escalating with NDSP to help you resolve.

I don’t have another device to try it with unfortunately. I’ve been talking with NDSP support for several days now and we’ve run through all of these, nothing has worked. As I said, it has been doing this practically since I got it.

Sorry to hear that! Are you using the OEM power supply? Depending on where you are located, I would strongly consider sending it in for warranty repair and let NDSP diagnose the issue. You don’t hear too much about USB audio noise anymore and cases are getting rare etc.

Everything I am using is what was supplied with the unit when I purchased it. NDSP customer support has suggested numerous things to try to fix it but nothing has worked at all. It just did it again now twice.

Maybe you missed this earlier…?

Edit; My post from a similar topic, and I’ve just spotted someone at the bottom suggesting something to try on windows machines by the looks of it. It doesn’t need drivers on a mac…

Also another post there with the same system as my new one (albeit older OS, I’m on 13.4) so maybe it’s down to the supplied cable? If you see the same numbers as I did in diagnostics, that’s the first thing I’d swap, as it’s so cheap. As I said there, I got a ugreen B to C cable, and it’s not glitched at all since then.

I did in fact totally forget about that, sorry. I unplugged and restarted it and it has stopped, but I’ll remember to do that next time to see if there’s anything going wrong in the unit itself. Also might be worth mentioning that I previously had an Axe 3 which never did this and I still have a 10+ year old Focusrite Saffire 6 USB that still does not do this to this day.

I tried changing the cable, it has not fixed my issue. Checked diagnostics and it seems like inWriteIdx, outReadIdx, outWriteIdx, all collapse to 0 when the issue occurs and USBAudioOutRdWrDistanceAverage goes up to about 500-600. This isn’t consistent though.

Update for anyone reading this…
This has not been solved. I just reinstalled Windows today, totally fresh with nothing on the computer except my DAW, some VSTs, few games, and the NDSP driver. Still getting the same issue. Tried switching to my 15 year old Focusrite Saffire 6 USB as soon as the QC had the issue, just moved the cable from the QC to the S6 without rebooting anything, turning anything off, or closing programs, and the S6 had no issues at all. Moved the cable back to the QC and instant problem.

This is telling me it isn’t a PC hardware issue, but it is on the QC. Also tried factory resetting the QC and running it at stock settings, still had the issue.

1 Like

is this after DL’ing the new update today? There are MANY hotfixes in it, one mentioned crackling but I’m not sure if it’s the same issue you’re having.