Quad Cortex will not boot up

Hi! Yesterday I had my first problems with the Cortex. Few hours prior to this happening it worked perfectly, but later the same day power-button and inputs stopped working completely. I tried with different cables, tried updating, tried older backups, even factory resetting with no help. I thought I’ll wait a bit and try again later.

Suddenly the unit didn’t even react when I plugged it in. Only a little light inside the unit lights up (I guess it receives electricity?) but nothing else happens. I also tried with my friends QC’s power supply, but had the same outcome.

Has anyone had problems like this and do you have any idea what could cause this? It has never gotten any liquids on it and I’ve taken proper care of it always. Never dropped or anything. I contacted support right after this incident and I’m waiting for response, but I thought I would like to hear if anyone has experienced this kind of issue. I couldn’t find anything like this in already existing topics.

There is this existing thread but contacting support which you have already done is the right method to get this resolved due to multiple variables. Good luck!

This is the neural answer? And now? You cant play?