I wish the WIFI worked as good as this thing looks and sounds

So I had this thing all packed up and ready to send back to Sweetwater. Could not connect to my WIFI router just down the hall. Then, I moved my router and was able to get a relatively weak signal. NOW, no internet connection. Reboot, Shut Down, Move router some more, try to connect to my hotspot (will not). So this amazing device has a WIFI that is not as good as a cheap phone. Everything else in my house works EXCEPT this Quad Cortex. I am typing right now on an iMac. Great signal. The unit sitting right next to it does not even see, recognize or connect no matter what. Such a disappointment. Does anyone have any idea what I can do?

1 Like

the first recommendation is usually to try a hotspot from your phone. Many have found this to be a solution. Have you tried the other suggestions from the official site?


Update: Apparently my XVive wireless in ear monitor which works at 2.4 ghz was interfering with the WIFI. A common issue that I did overlook. I suppose I can change channels on the XVive, but for now since I know it is the cause of interference, I can simply make sure it is not on when I want to download something. I still wish this thing had a better WIFI antenna in it, but in this case it was operator error. Thanks for listening.

Yes, I have tried them all. ALL of my devices hook up to my router just fine. I moved it to get closer to the router because apparently it has a super weak WIFI antenna in it. It was working for the last few days and now it will not connect, period. I reset my router and all of my other computers are seeing the WIFI access just fine, but the QC just sits here. It absolutely will not hook up to my iPhone 13 Pro Max no matter what. The computer sitting 2 feet away from it hooks up instantly to the Hotspot, but the QC… nothing. It is a shame that it is working so poorly. So yes, I have looked at all the common WIFI issues with no results. A bit frustrating. Thanks for the input.

1 Like

sorry the usual solutions aren’t helping. I’m sure support can try to walk you thru it when they’re back on Monday (ouch, the wait!) but they’ll probably start with all these steps you’ve already tried.
Do you possibly have a non-standard character in your user name or password? I’ve heard of that being an issue in the past.

The weird thing is myself and many others experience no Wifi issues. I suspect it’s more a case of an deeply buried incompatibility somewhere network-wise. I’ll check w/ @RexRemus on Discord, I remember him saying something about having to go to some unusual lengths to link his statically or something like that.

1 Like

Thanks Xush, Please see my update… It was a self inflicted wound. There are a lot of things that work on the 2.4 ghz band… therefore the problem! Appreciate you. I love this unit! Except its WIFI weakness!

1 Like

Ah, interesting. Hopefully your solution might help others, that’s what this place is all about

1 Like

Yeah, that’s why I left it up. My pride is slightly injured but hey, we are all mostly human. :wink:

1 Like

My QC is essentially a giant paperweight on my studio desk. I can’t get it to connect to my robust wifi network 90% of the time. With no desktop editor this unit is pretty worthless.


Mine lives on my desk, i use the editor which is still clunky, but a good start.

However when I need to download something… I have to pick it up and walk it the 30 ft into my living room for wifi to connect. Its very apparent at this point this is hardware issue and not something they can address with a firmware update.

The best they can do is hopefully allow the device to sync to the cloud via the USB connection. I agree the wifi functionality is basically useless at this point.

Their expectation that I am going to use a phone hotspot when my access point is 30 feet away and provides internet to my entire house including multiple 2.4 and 5g clients. It’s just stupid.

The QC sounds great, but the wifi causes more problems than it helps with. Bluetooth to a desktop editor would be a better option.

That feature is implemented. The QC uses your computers network when connected to Cortex Control.

1 Like

Mine throws errors pretty constantly when its trying to deal with downloaded presets. So likely just some bugs to keep working through.

But that’s a positive.

My QC connects to my wifi consistently - but that’s all it does. Updates consistently fail.
Fortunately the hotspot solution is reliable and - thankfully - updates as well.

In defense of the QC I must note that it isn’t the only device on my home network that doesn’t work. The other offender is a Google Chromecast that absolutely refuses to see my home network.

I’ve tried a whole lot of tweaks on my router to see if there is a work around, but so far, nada.

Have you guys used a wi-fi meter on your phone or laptop to check the signal in houses? Look at which channel you are using and perhaps switch to a different one?

Have you tried a cheap repeater half-way between where you have the QC and your router which could give you better line of sight?

1 Like

Make sure you have a separate SSID set up for your 2.4Ghz band. Don’t use a combined 2.4Ghz and 5Ghz SSID.


some routers wifi arent set to support legacy options for the 2.4 band, they often have settings optimized for speed vs compatibility, like b/g/n compat, and 20hz vs 40hz try playing with the band settings, and also the advice someone else put up about a separate SSID and not joined stuff like HonestOpinion said.

1 Like

I did create a 2nd SSID, but i suppose i could play around with the 2.4 band settings. It would be great to know what it is SPECIFICALLY looking for.

Halfway would literally be 15 feet down the all in my hallway. My office is not more than 30 feet away from the AP.

"Something went wrong. Please try again. If this continues to happen, please contact support team citing. “Error Code 401”

Every single time

That “401” appears to be a login error. Sometimes that error can be due to an issue with your local cache (not sure if that is relevant in your case), for example a browser’s cache, or due to logging in incorrectly, but it could be something that needs to be corrected on Neural’s side. I would contact Neural support regarding your login, might be the source of the problem.

Well download one if the meter apps for your phone and see what signal strength you are getting and how busy the channel is.