Defective Wi-Fi in unit/bug?

My unit can’t seem to hold a connection and once that connection is lost, it endlessly keeps trying to look for other networks and doesn’t show anything. This problem also seems to mess with the power function, because whenever these exact series of events happen, the shutdown/reboot prompt fails to show and I have to restart from the settings section or unplug the power. I’m well within range of the access point, so I don’t think distance is a factor. Did I just get a bum unit?

Hey @BigMcLargehuge. I’m sorry to hear that.

Please send a ticket to support@neuraldsp.com. Make sure to include your QC serial number.

Thanks!

Very interesting. The first time I used the unit I had trouble with WIFI connecting. Its been fine since.
However when I had the issue I couldn’t restart the unit via the power button. So I bet its related to the issue you had.

Some folks have observed that their WiFi reception varies with the orientation of the device. Maybe try rotating it and see if that affects your signal strength.

I’ve tried it right against my router. Nothing.

Did you try rotating? Also, the directional issue is likely to be exacerbated if the QC is super close to the router.

So I should be neither close nor far from router? Sounds counterintuitive. If I’m near the router, what difference does rotating the thing do? Is the wi-fi hardware in the unit really that bad to begin with? I’m just going to assume I got a bum unit because literally no troubleshooting works.

The only place where radio signals can get in/out of the box are through the grills on the side. Your WiFi signal isn’t going to penetrate several millimeters of aluminum even if the QC is sitting on top of the router.

As for being too close, think of the side grills as a window. If something is close to the window but not in front of it, you’re not going to get a good view of it. If it’s farther away, it can be farther off-axis but still in your field of view.

If you’re still with me, the idea is to be close enough that the signal is strong, far enough that you have some margin for error, and have the QC oriented so the router is “visible through the window”. It doesn’t need to be sniper accurate but you’re fighting physics if if you have a solid chunk of aluminum between the QC’s antenna and the router.

If you do end up opening a ticket with NDSP, they’re gonna ask you to check the RSSI for your WiFi network. It’s under the QC’s WiFi menu.

My RSSI is well above the acceptable -60dBm range, so I really don’t think it’s a range issue. Even then, the problem also seems to make the power button non functional (yes, I closed out the menus to the main block page before doing so).

I hate to be bitchy about it, but a unit like this shouldn’t have to be manipulated like a pair of old TV antennae for it to function properly. That just seems like a miscalculation on NeuralDSP’s part.

If your signal strength is good, you’re right. There seems to be something amiss.

I would check you wifi setup. I have a router that was causing problem with our iPhones. I found it to be a box checked for some kind of newer wifi switching. The QC runss 2.4Ghz I don’t think devices with 2.4 do well with some of these settings.

I have, though…

Take to a family or friends house try it and see how it works on another network. What router are you using?

1 Like

Here’s a video of what happens. Still having a back and forth with NeuralDSP and nothing is working. I’ve tried hotspots, too. It seems like every unit in my house with wi-fi capabilities work except the QC, so I’m going to assume that there’s just something wrong with the unit.

looks like a manufacturing issue. my wi-fi works fine @ -63dBm

I constantly lose my Wifi settings. Sometimes it even loses the Wifi password. And yesterday it lost everything … even the login to my NDSP account…

I raised a ticket with them and they promptly replied. The answer actually implied that I use my phone hotspot to update the unit instead … wtf ??? They also directed me to a support page, that does not solve any issues. My signal strength is -64dB, so I’m well within the range. I assume it’s a faulty part or design.

I need to respond back to them still, that my issue is not solved.

Cheers, Todde

I have also lost WiFi settings etc. a few times. It got better with CorOs 1.0.3, so far it has been Ok
after that.
On the otherhand , multiout vs out1/2 behave weirdly with USB & MAC & reaper combo.

cheers,
Timo

Is there no way to update the firmware via USB?