Defective Wi-Fi in unit/bug?

I have tried all kinds of things and I’m about to give up. I waited for over four months and spent tons of money on cables and an active frfr and I can’t even update this thing. I’m not really computer savvy so creating a hotspot for example takes research, trial n error. I have never had this issue with any devise ever. I set my modem to 2.4, I have full bars and -30dbm. I don’t really know or care what any of that means but my understanding is that my internet speed and settings are optimal. I’ve spent about three thousand dollars and many hours trying to fix this. So far customer support has not given me any solutions. They’ve asked me to send them a video so I did and I’m waiting for a reply. Thank you for your response, I appreciate your help. Cheers

I’m using Windows 10, but here’s what I tried that worked:

  • Right-click on the wi-fi icon in the lower right hand corner
  • Select Open Network & Internet Settings
  • Select Mobile Hotspot on the left hand menu
  • Enable Share my internet connection with other devices
  • Use wi-fi and not the bluetooth option

You will then see the name of your device and the password to use the mobile hotspot.

While I’m happy to know that it might not be an issue with the hardware, I do think it’s weird that it only works for me in this particular configuration and doesn’t work connecting directly to the wi-fi.

Hello everyone. I will share my observations, maybe this will help someone. The fact is that if your Internet provider uses a dynamic IP for clients, then the QC cannot “tether” to the network. For its normal operation, a real IP is required. I have tried this more than once. Peace for everyone!

it seriously annoys me that this issue is happening time and time again and the standard response from everyone is ‘check your router settings’, or a template NDSP support email that more or less ends with ‘use your phone as a hotspot’.

If literally every other piece of gear on the planet doesn’t have trouble connecting to someone’s home wifi network, why would it be the router or the user that’s the error? Let’s call it for what it is - an issue with the QC hardware.

1 Like

I took my cotex over to my mother’s house and it worked fine with her fifteen year old modem and relatively slow connection. I was convinced it was a bug or hardware malfunction but now I think it does have something to do with internet settings. Even if that is true it’s really disappointing that it requires such specific settings. I have never had this problem with any other device and considering the cost I find it ridiculous. If they were going to use a wireless system that’s apparently outdated(?) and super picky then they should have included a line out so you could connect directly to a modem. I’m loving the tones I’m getting and the simple interface is great but this is almost a deal breaker for me since updates are so necessary. I’ve spoken to Natural and my internet provider several times and no one can tell me anything that has worked. I guess I’ll be spending more time with my mother. Whatever you do, don’t say “hotspot” or I’m going to throw my cortex through the window lol.

2 Likes

This is not the issue here. Most people have their own internal wifi that is routed via their provider’s router to the Internet. Most the issues with wifi is actually centered around connecting to their internal wifi access point. What you are referring to is how you connect to the provider which is usually NAT/PAT using a private subnet. Unless your wifi network is using registered addressing, you can configure using a private static or dynamic address and it won’t prevent the QC from connecting to your wifi either way.

As long as I can remember, I have had only two devices that were problematic connecting to my wifi. One was a HP color laser printer and the other was a Carrier HVAC thermostat.

I resolved the printer issue by generating and using a static IP. HP couldn’t help and no idea why a static address resolved my issues but it did. The thermostat was resolved by changing my SSID. It was previously not advertised and that resolved the thermostat issues.

Has anyone tried using a static IP? Has anyone removed WEP, WPA, WPA2 etc., temporarily to see if that resolved the connectivity issues? I have also heard of weird issues where the SSID had characters that weren’t permitted and resulted in no connectivity. The fact that this wifi issue is not wide spread, says there is possibly conflict with specific models and or chip sets. Unlikely but if so, I don’t believe that would be resolved via firmware.

If it is a chip set in specific model do you think a different unit might not have the same issues? I would assume all the cortexs are the same but it seams odd to me that only a small group of people are having this problem since so many people have xfinity wifi.

I bought a cable that allows me to plug my modem into my usb-c only laptop and then created a hotspot. My cortex found the network but after entering the password nothing happened except all the networks shown greyed out and wouldn’t let me select anything in the box. So that cost me twelve dollars and didn’t work.

Chip sets in the home wifi models available, not the QC. I assume each QC is exactly the same regarding the wifi module used. Anyone using their provider’s wifi router/modem only will likely run into problems anyway and would suggest to use your own wifi router behind the provider for (much) better security, safety concerns and ease of use. Remember, Comcast/Xfinity only operates in the US (40 states + DC) so anyone having issues with wifi outside of the US would have zero to do with Xfinity.

Again, has anyone tried using a static IP? Has anyone removed WEP, WPA, WPA2 etc., temporarily to see if that resolved the connectivity issues? I have also heard of weird issues where the SSID had characters that weren’t permitted and resulted in no connectivity.

Anyone with wifi issues should try that and report back, plus it would be helpful information for NDSP I would assume. Good luck!

Got same issues at 1.3.0 and 1.3.1 firmware. Updated to 1.3.2, it works well.

1 Like

Hey there,
As I was trying to conect to my WiFi today to download the latest update I got the message “obtaining ip adress” on my QC as it tried to log on to my Wifi.
Tried a few things but switching the router off and the hotspot of my iphone on worked, as I was then able to connect to the phone, which oddly wasn´t possible while the “obtaining IP adress” message was displayed.
Peace!

Hi @Mildael and welcome to the community! Make sure your SSID doesn’t have any weird characters embedded in it as the QC won’t be able to connect to the wifi. Also make sure there is nothing blocking the QC from connecting to your AP. The fact that your QC can connect to your hotspot and not the Wifi AP, might indicate a simple configuration issue on your AP. Worst case, please reach out to support@neuraldsp.com and they will take care of you.

HelloHello!
Thank you kindly for your helpful response. I´ll check it out. So far very happy it worked with the HotSpot and VERY happy with the update, the QC is even better now.
Can´t wait to gig tommorrow…
THANKS!

1 Like