CorOS 2.1.0 is now available

No, why should it do that?

Because it would be clever and helpful?


For your use case as a global volume control it may be useful. But imagine a preset with a split to multiple rows and the volume block only on one of those rows to e.g. control the amount of effects mixed into the main signal. In this case you would not want the tuner screen shown everytime you have the exp pedal at 0. Long story short: Global Volume control isn’t the only possible way to use the volume block.


exactly - probably not something to attach to a block, but rather to a pedal as a global assignment? So for a specific pedal port, have an optional setting “show tuner when 0”.

I find this function quite useful on my Kemper - makes things super-simple when using a “classic” volume pedal - “heel” the pedal and tune.


That would be awesome, easiest way would probably be the option to assign an external pedal to the global volume control that is controlled by the big wheel on the left + the option to activate the tuner while on 0. Maybe add the logarithmic option like the new volume block has also for the folks that are used to the classic feel of analog volume pedals.

EDIT: The more I think about it, though, the more I think volume control and tuner activation should stay separate - at least for my way of using both: Live I mute the signal completely between two songs, when I feel I have to tune / have the time for it, I activate the tuner. But often, before the next song starts, I change the preset or scene. If the tuner now occupies the whole screen during the entire break, that would be very inconvenient, because you can no longer see the presets / scenes without unmuting the signal. My wish is therefore still that the tuner can be activated instantaneously or that all switches can be assigned to any device functions (as in the Helix Command Center).

If you feel the same, please vote for the following feature requests :slight_smile:

Most of the features are great, but still missing in action is the ability to assign any combinations of preset, stomps or scenes to the footswitches. Hybrid mode is not the answer. I hope they get to it soon.


I use the auto-engage tuner setting at heel-down on my Fractal and agree, very useful. If they do implement it on the QC, I hope they include one improvement. I would love to see an additional global setting for the tuner at heel-down (or toe-up) that allows an auto-engage delay setting in milliseconds. One annoying thing about the tuner activating at heel-down is that it pops up when you don’t want to see it, as other users have alluded to, when you are using the pedal for whammy, wah, other effect block parameters, or even volume swells.

That way, when you are moving the EXP through its full sweep, you could set the auto-engage delay for the tuner to 50ms, for example, and either rarely or never have the tuner screen pop up when you don’t need it. You also of course need to still retain the usual options for a tuner such as mute or thru.

1 Like

I’ve been asking for this for a while. Helix allows you to remap every single footswitch to any function and even to send midi messages. The options at that point are endless. QC’s processing power would really be maximized if they allowed that option.


hopefully soon/eventually!
once they release cortex control and plugins i´m sure they´ll work on that and with at least the volume block and other stuff we have work arounds for now

It’s true. L6’s command centre is the best system out there. I’m not sure if NDSP actually wants to implement that. But definitely, we need cortex control before we can even consider having something like that

Has anyone gotten the new volume block to work? I tried replacing my gain block with the volume block but for some reason, the same foot pedal doesn’t seem to work?

I already tried re-calibrating the volume pedal via the I/O settings Expression page.

Is there something else I should be doing?

it should be the same procedure as assigning the XP to any other block. You haven’t changed any physical connections? Have you hard rebooted since the update?
Try assigning the XP to something else, just to make sure it’s not a bigger issue.
Then try rebooting a couple times.

Have rebooted the device multiple times and am using the same physical connections. I changed the volume block back to the gain block and it works fine. Quite lost what could be the issue.

try DL’ing my preset where it is already configured and see what happens. There are no external captures in this. It should preconfigure the Vol block and Wah to toggle with a toe-switch, and XP1 should control the Vol on the default scene.

If that doesn’t work for you then you may have a bug to report

Have you also selected the Volume block for edit and gone into the context menu (three dots) and assigned your XP to the ‘LEVEL’ parameter? As @xush already described in an earlier post you can also use the ‘Set parameters as default’ selection, also under the context menu, to have it come up this way any time you include the Volume block.


That worked! Thank you!