Worst user experience

Hello guys,

I will paste here my email that I already sent to support, maybe somebody already had this problem and i can fix it faster:

As the title hints, i am not having the best of times with my new qc, to say the least.
I have just unboxed and wanted to update the software right away so i tried connecting to my home wireless that works on all of my devices across my house.
I have two routers, one from my internet provider and another tp-link that i have as an extension.
After i tried connecting to the tp-link a couple times, it worked, it said connected, then it got the ip-adress, then i logged in into my account which surprisingly worked and then i tried doing the software update and here all went to dust. The qc said it was running the latest software but it s running 1.4 straight out of the box. After all of this i tried to send a report but it said to check my connection and try again ( also i should mention i am standing 1 foot away from the router this whole time). Then i tried using the internet provider router, after putting in the password, the qc got stuck, it started working very slowly, even when i went back to the main screen with the presets, if i wanted to change the preset it would take like 5 seconds to do it after pressing the switch, so really slow.
I tried to start fresh, factory reset the qc, factory reset both routers, no luck. Still working slow and saying it s up to date when it s clearly not.
How should i proceed regarding this situation?
I bought this unit to use it live and in studio because i really love your plug ins and the qc tones but being this unreliable i don t know how i am going to be able to do that.

Thank you.

there was a problem with the new update that causes crashes so they disabled all updates

1 Like

The updates have been temporarily disabled due to a bug some have experienced per NDSP. Also note that the QC works with 2.4G WiFi only. If it connected via your WiFi extension, I would continue to use that process. Regardless, with CoreOS 1.4, the QC shouldn’t exhibit slowness issues therefore I would definitely recommend to email support@neuraldsp.com and they will get you sorted.


I had the exact same problem after 1 year of working flawlessly. Then one day it showed I was connected as usual but would timeout every time I tried to back up. I did a speed check on the 2.4G side of my router and discovered it would only upload at 1Mbps and the 5G side at the usual 500Mbps. I replaced the router for $99, both bands are now back to 500Mbps - problem solved!