Brand New QC: Login / Update Issues

CorOS Version: 2.0.1

Describe your issue:
Im connected to internet, says there is connection but when i log in or update it fails to connect to the server. I cannot use my quad properly as I need the updates and will need them in the future.

Steps to reproduce your issue:

  1. Factory Reset
  2. Settings Reset
  3. Connect to Wifi -60db
  4. Login FAILS

I expected this to happen:
It should work as this is a vital feature of the QC

I have tried the following things:


If you are connecting over a wifi router, try a hotspot on your mobile phone instead. See this thread for more.

NDSP is working on a solution but isn’t there yet.

I have tried various troubleshooting aside from the reply of the support which is to reset / factory reset

I tried 3 wifi locations and 1 hotspot of the same network provider.

Today I will try a different network provider from my friend to see if it will work there.

Weird thing is it connects to wifi and says its connected but doesnt connect to the servers. I think this must be some server issue i hope can be fixed remotely as shipping this back to neural is a pain to do here in ph

The odds are good over a hotspot on your phone. You should be able to link to Cloud Cortex over that, and if you are lucky, also do backups and updates. I wasn’t so lucky - I could only link to Cloud Cortex and do backups via the mobile hotspot. However, once I had it linked, I could do updates after reverting to my wifi router connection (over which I could not link to Cloud Cortex). Yes, it is weird.

I don’t generally have problems connecting, but I did struggle with finalising one update. My solution was to unplug everything from the QC, and temporarily move it to a location within inches of the Wi-fi router. I only plugged in the power, and dealt with the updates in a position where the wi-fi signal was pretty much guaranteed to at its strongest.

Update: My unit is now on its way to finland through ups service… I hope all goes well.

UPS reviews here in our country is so bad I just hope my qc is safe

Neural DSP doesnt want to use other carriers which worries me so much

Oh, sorry to hear this. So logging in via a mobile hotspot didn’t work for you.
Good luck with the repair process - sending some karma your way!

Posting this here since i dont want to create a new thread

I have had issues with my qc since i bought it september 23…

  1. I cannot log in with any account

  2. I cannot update the quad

I have done everything the has told me.

  1. Reset through recovery mode

  2. Factory reset through recovery mode

  3. Reset from settings

  4. Factory reset from settings

Just to give a background I have work experience with software development so i decided to do RND on it on my own.

The support team have been asking me to send back the unit for repair but i really have some gut feeling that this is a server issue because 2 of people i know in ph has the same issue. ( i have said this support team since day 1 of my inquiry they snob me)

Just because i don’t want to wait months to get my unit repaired i decided to try to create virtual vpn router from my mac.

Then voila! It got updated and logged in succesfully, but now the issue is i cannot use this QC without a VPN.


This is just a half fix they still need to address server issues

1 Like