Volume jump when using gain utility as volume control with expression pedal on row 4, position 1

CorOS Version: 1.0.1

Describe your issue:
when I insert a utility block (gain) and use an external expression pedal as a volume control assigned to the level parameter, there is an unexpected quick volume jump when switching scenes. This jump only happens when the block is placed on the lower rows and does not occur if the block is placed on the top row.

edit: On further testing, i have also noticed this volume jump on other blocks when switching between scenes with a bypassed/active state where the block is on row 4, position 1.

Steps to reproduce your issue:

  1. created a utility block (type: gain) at the start of row 3 (being fed by row 1)
  2. assigned exp pedal to control level parameter (-60db - 0db range)
  3. when switching scenes on preset where the block stays on, there is a distinct quick volume jump

I expected this to happen:
when switching scenes, I expect no volume jump when block is placed in any position on the grid.

I have tried the following things:

  • i can achieve no jump by moving the gain utility block to end of row 1 or another position on Row 3.

I’ve experienced some similar issues when the gain block wasn’t first. It was either at bootup or changing presets (don’t recall now) that the gain block was maxed out when the expression mapping shouldn’t let it go beyond 50%.

On further testing, i have also noticed this volume jump on other blocks when switching between scenes with a bypassed/active state where the block is on row 4, position 1.