Volume block won't go to 100% even after calibrating expression pedal

Hi All,
My expression pedal has been properly calibrated. When I used the Gain block, it went from 0 - 100 no problem. Since using the Volume block, it will only go from 1 - 50, even if I manually turn the knob to 100 and save it/set it as default, the next time I rock the pedal, it will only go to 50. What am I doing wrong?

what model XP are you using?

This preset pre-configures the Vol block for 100% on XP1, you could try it and see if you still have the 50% issue.

1 Like

I’m using XP 1. I even just updated to CorOS. 2.1.1, to no avail. See video link: https://youtu.be/q0HCiG-0rLA


This is operating properly as designed. The new ‘Volume’ utility is at unity at 100%. It is intentionally working differently than the ‘Gain’ block.

Edit: Never mind, just saw your video. I would try deleting the volume block if you haven’t already and adding it again. Maybe try it in a different preset as well. The 2.1.1 CorOS update is out today. Maybe updating might help.

that’s really weird. Does it do that with my pre-configured preset also?
I use the Mission pedal w/ XP1 as the pedal and XP2 as the switch.

Saving the settings as default should only memorize the XP assignment, it wouldn’t save the position of the knob at 100% because that is always relative to where the pedal position is at the moment.

Strange. Can’t duplicate that issue here.

With which of your pre-configured presets?

The one linked in my first reply to you above

Got it, thanks! Using your preset it now goes to 92.2%, which is much better than 50%. It bothers me that it’s not going all the way to 100, and that I can’t set one up myself that will go to 100. Thanks for your input, though. This will get me through til I can figure out what’s going on.

1 Like

that is really strange. Does it go to 100 on other blocks, just not the Volume?

Did updating to the latest firmware fix it? Btw, you probably already tried this several times, but just in case, did you do a recalibrate the expression pedal and save recently? Hopefully after the latest update.

Also, clutching at straws here, make sure you are using a TRS, not a TS cable and double check both ends are pressed in all the way.

Also, select the volume block and take a look under the context menu (three dots) at the ‘Assign Expression Pedal’ option. Make sure the ‘Min Range’ = 0.00% and the ‘Max Range’ = 100%.

1 Like

Ok, well, I did update the firmware yesterday. I just now recalibrated the expression pedal, and now it’s going to 100. I calibrated it yesterday and it wouldn’t go to 100. I have no idea why it worked this time, but I’m just glad that it did. Thanks for your input!