Problems with Neural DSP

I have a laptop with 32 gb ram and a 2.6ghz intel i7. I have been using the line 6 toneport UX2 for my audio interface, and was getting a lot of latency, even with the lowest sample rates in the various Neural DSP plugins, so I figured upgrading the audio interface might be worthwhile. I purchased a Focusright Scarlet Solo 3rd gen, and the latency is even worse than before.

What can possibly be going wrong? The latency is so bad I can’t play using these plugins.

I followed these procedures as well. It seems like I’ve done everything I’m able to do here.

Hi @nanthil. Please attach a screenshot of your audio settings.

1 Like

That is the lowest buffer size I can set through the UI. It doesn’t have any other settings.

I’m using windows audio because direct audio sounds like a spastic white noise generator hyped on too much caffeine gargling shards of glass while falling down a flight of stairs, so windows audio is the only option.

Also 44100 Hz is the only sample rate I’m allowed to choose.

@nanthil Thanks for the screenshot.

First of all, you need to install the ASIO drivers included with your audio interface. Check this link.

After you’re done with that, you can configure your audio settings. Select << none >> as the Audio Input Device and Audio Output Device, then switch to ASIO at the Audio Device type. Finally, select your audio device, sample rate and buffer size. Your Audio Settings should look like this:

  • Audio Device Type: ASIO
  • Audio Device: Focusrite USB ASIO (This can vary depending on your audio interface)
  • Audio Input Channels: Input channel 1 or 2 (Just leave one input enabled)
  • Sample rate: 44100 Hz
  • Buffer Size: 128 Samples

If you encounter crackling noises and audio dropouts after using those settings, follow this guide to optimize your system.

1 Like

Wow! So it really was the audio device. This sounds incredible compared to use the UX2. It all sounds so much better on the focusrite, and with no latency. Finally!

Now that I have a input device that isn’t 15 years old, what do the different settings (from the image) actually mean? And how do I tune them? I messed around with them and I’m not noticing a whole lot of difference?

The sample rate is the frequency in which the original audio signal is sampled to be converted into digital audio. A sample rate of 44100 Hz means that the signal is being sampled 44100 times per second. You can increase the sample rate to obtain a better resolution, but as a rule of thumb, to accurately reproduce the original signal, we need a sample rate twice as high as the highest frequency we want to reproduce. Most humans can’t hear beyond 16 - 18kHz, which means that 44.1kHz or 48kHz is more than enough to accurately reproduce the entire audible spectrum.

The buffer size indicates the number of samples per “batch” of audio that’s processed by your system. Lower buffer sizes lead to lower latency at the cost of more CPU usage. At 128 or 64 samples, the latency is negligible. The sample rate also dictates the “duration” of each sample, which means that a buffer size of 128 at 48kHz will be shorter than a buffer size of 128 at 44.1kHz.

As mentioned above, the optimal settings should be around 44.1kHz and 128 samples. Our Plugins also include oversampling, which solves any potential aliasing caused when processing the signal internally sampling the audio at a higher sample rate. You can learn more about this here.

1 Like

@Gonzalo You rock. Thanks for the help today.

@nanthil No problem!

1 Like

I think the answer to my questions is likely obvious, but I need guidance and help (I’m a newbie to plugins, etc.). I have a new 2020 MacBook 13" with a 3.2 GHz quad-core processor and I just installed the trial version of Fortin Cali Suite. I’m running it through my only audio interface - a 2012 Presonus Audiobox 44VSL. It sounds terrible. There’s little latency; that’s not the problem. It just sounds awful, no matter the setting in Fortin Cali Suite.

Again, I think the answer is likely obvious, but does it sound terrible because I have an old, entry-level audio interface? If so, what audio interface would you recommend? This is for home recording, tone-chasing and fun. I could get by with two inputs but would prefer four. I’m hoping to spend no more than $500.


Hi @timgugerty. Before looking for another audio interface, check if you experience the same issues with another Plug-in. Install the trial for the Omega Granophyre (for example) and verify if it happens the same or not.

Thanks for the quick reply, Gonzalo! After review this form I used a shorter cable from guitar to interface, which helped. The problem I’m now experiencing is that I along with the tone I’m hearing from the amp, I’m also hearing another, very flubby, guitar tone. So, if I’m using a high gain setting in the Cali Suite or Nolly (which I also downloaded per your suggestion), I hear a flubby, dry signal at the same time. I’ve tried using my headphone out, line outputs, balanced XLR outputs and am still hearing this odd, dual tone. Any suggestions?

You need to disable Direct Monitoring. Move the Mixer knob all the way to VSL.

Egads. Can you tell I’m a newbie? Of course, that took care of it. I’m off and ripping. Thank you so much, Gonzalo!

@timgugerty You’re welcome!