Latency issues. How to fix them

Hi folks, I was wondering if someone could help me in case I am missing something. I downloaded the plini trial and went to try it out. The lowest amount of latency I can get is 3.0 ms so when I play there is a fairly noticeable delay. My computer has an I7 processor and 16GB of ram. Which I believed to be more than enough to deal with the software. I have a focusrite scarlett solo gen 2. Hoping someone can tell me how to fix this or if I’m doing something fundamentally wrong. Thanks in advance.

1 Like

Hey there! Please, change the Audio type to “ASIO” and the output to “Focusrite”. Maybe you’re using the wrong settings :wink:

2 Likes

3.0 ms of round trip latency is actually quite fast. How are you monitoring your sound? Are you using standalone or a DAW?

Hey bud! I’ve got the same specs as you describe. I use a focusrite scarlett 2nd gen.
The minimum latency I play with is around 2 - 1.5 ms. Try decreasing the sample rate until you get a desired result ( lowering this off limits can lead to crackles in the output sound).
I’ve been playing live with this rig and I’ve got no issues yet!

I have Macbook Pro 15 mid 2015, 16Gb RAM, i7

I use Focusrite Scarlett 4i4 3rd gen and with this setup I get to 2ms latency when using Standalone mode.

Just to give you guys a preference: Kemper has 3-5ms latency and Axe FX 2 and 3 have 1ms latency

If you get your latency under 5ms you should be more than happy.

If you get delay on 3 ms, it could be what you have plugged your interface in to a usb hub, or usb 3. be sure not plug it into a usb hub. There could also be issue with wifi, or Bluetooth interfering with the signal chain. Usb ports are also built into branches. Say you have another slow usb device plugged into the part of the same usb branches, it could interfere with speed. Its best to have interface completely by it self if that can be done.

This article is a good help to short some issue out and make computer even better fitted for sound. This guide can be used for other interfaces to.

Good way to start error search and short delay out is to start with a sample rate at 44.1 kHz and buffer at 128. Even some older computer should manage that. After that you can raise/lower the buffer until you get nice result. then you can alter higher sample rate to suited level, and in the end again adjust the buffer.

1 Like

Thank you all. I managed to stumble across the ASIO setting. Thank you all so much for your help though! \m/

2 Likes

3ms of latency is pretty low. Stand a few feet from a real amp and I believe you’re getting about the same. As has been said, under 5ms is all good. Mines at 2.2ms 96 buffer but if I buffer at 128 its 2.9 and its more than fine