Neural DSP Latency

I’m having latency problems with my Archetype Abasi and although I’ve tried to fix it, it doesn’t seem to work.

I use a Focusrite Scarlett 2i2 2nd gen interface that goes into my laptop and I use my laptop speakers for the audio output. I’ve tried reinstalling the ASIO drivers, the plugin itself, and I’ve tried lowering the buffer size as well but none of that seems to fix the latency.

How can I fix this issue?

Hey @lost_plectrum. You need to connect your speakers/headphones directly to the audio interface. Otherwise, you would be bypassing the low-latency ASIO driver.

Your audio settings should look like this:

  • Audio Device Type: ASIO
  • Audio Device: Focusrite USB ASIO
  • Audio Output Channels: L and R or 1 and 2
  • Audio Input Channels: Input 1 or 2 ( Disable all the inputs you’re not using )
  • Sample Rate: 44100 Hz
  • Buffer Size: 128 or 256 Samples

These are the audio settings on Neural?

You can modify them, but with those settings the latency shouldn’t be noticeable. Are your speakers already connected to your audio interface?

I usually use my headphones but I haven’t connected them to my interface so far.