Plini CPU usage

I’ve just installed Plini and noticed that it’s significantly more CPU intensive than the plugins I’ve tried before. For instance, Fortin Cali Suite takes up around 20% CPU, whereas Plini consumes 60-70%.

Audio Settings are identical for both plugins (48k sample rate, 128 buffer size, mono). In fact, with Cali I can even go all the way down to 32 sample buffer with no measurable increase in CPU usage and no sound degradation, whereas Plini is occasionally cracking at 128.

I’m not running any effects, both plugins have only the Amp and Cab sections enabled.

My computer is a MacBook Pro with 2.9 GHz 6-Core Intel Core i9, running macOS 10.15.6 (Catalina).

1 Like

Hey @Max. What are you using to measure the CPU usage? What’s your DAW?

Thanks for the response, @Gonzalo. I’m using the standalone applications, both are at the latest versions, recently downloaded. Measuring CPU usage with Activity Monitor.

I went through the optimization guide in the FAQ and installed Intel Power Gadget as suggested on another thread. There’s no CPU throttling as far as I can tell:

The most puzzling thing for me is why Cali performs so much better in a straightforward 1:1 amp sim comparison, with all the extra features of Archetype Plini disabled.

If you’re using the Activity Monitor to measure the CPU usage, Keep in mind that the percentage showed in the % CPU column corresponds to the approximate utilization multiplied by each logical core of your system (100% per thread). This means that if you have a 6-core with hyperthreading, the maximum utilization will be 1200%.

I sent you a legacy version of Archetype: Plini. Please check if your experience the same issues with that one.

Yeah, I’m aware how this works, however this theoretical limit of 1200% is largely irrelevant for Plini since it’s not built to take full advantage of multicore CPUs, so it’s bottlenecked by single thread performance (like most audio plugins). I can confirm this by examining individual threads using ps -M {pid} command in the terminal - the majority of CPU time is concentrated in a single thread.

The older version of Plini you’ve sent me appears to perform better, though still not quite as good as Cali. I’m seeing around around 30% using just the amp and cab, 40% with delay and reverb.

In case this may be helpful to your team, one curious thing I’ve noticed while investigating the process is that the latest version of Plini is the only one that appears to be doing something computationally non-trivial on the main thread of the process, in addition to what appears to be the main audio thread. Older Plini and Cali are spending less than 1% on that thread, while new Plini 10-15%. It may be a symptom of some kind of bug.

Thanks for the update.

That’s correct. However, I’m still not sure what could be causing that difference in performance. We expect some amps to utilize more CPU than others, but in the case of the Cali and Plini is usually the other way around. I’ll send the info you gave me to the dev team.

Do you still experience crackling/underruns with the legacy version?

I have also noticed a heavy CPU usage on Mac OS 10.14.6 (5K I7 iMac w/64GB Ram). Compared to ML Soundlab ML5 plugin, the Plini is double the usage). Also, when I close out the desktop app, the spinning beach ball runs for a couple seconds before the program closes. That being said; the Plini plugin is one of my favorites.

Unfortunately, same goes here.

I’ve recently purchased the Plini. I’m experiencing around ~75% CPU usage, no matter what is the selected buffer size and which effects are enabled/disabled and whether oversampling is enabled or not. I’m on a Macbook Pro i7 Quad core 2.4ghz.

In comparison, I’ve also purchased the Archetype Nolly (fantastic!) which takes between 25-35% (changes based on buffersize and oversampling state).

This is definitely something which needs to be addressed, 75% CPU is not legit, no matter how high quality and great sounding the plugin is (and it is).

On another note: I’ve emailed about this to support a week ago and haven’t received a response. That is a bit of a letdown but I assume you might be pretty packed because of Black Friday, Holidays, etc’.


Hey @mikeyshiran. Just went through the support inbox and I think we haven’t received any ticket from your email address. Are you sure you wrote the correct address?

Hi @Gonzalo.
The email I’ve sent my query to was And it’s my bad - wasn’t one week ago but a few days ago on December 1st.

@Gonzalo? any updates on this?

Can you send me (through DM) the email address you used to contact us? I can’t find any ticket from you on the support inbox.

@Gonzalo sent. Thanks for handling this.

1 Like

we need update for this, i am also having CPU spike with PLINI everytime i used it … :frowning: