"Occasional Audio Glitches as USB Interface" Thread from 2021 no solutions yet?

Here is a simple solution I found where I can bypass the USB cord and the weird noises that go with it. I bought this and it works great. 40% off right now. It is a powered 4 channel mixer. I can get my source audio from my iMac and plug my guitar from my QC into it and listen with my headphones. So I am a happy camper. Here is the link if you want to get a mixer with no need to deal with a DAW.

A few months back I tried to use my QC with my Apple computer as an audio interface and would get weird robotic glitches no matter what I tried. I essentially gave up on it. I was just reading this thread from a few years ago which is closed now. Was this problem solved?

To this day when I try to play any kind of audio through the USB from my iMac, MacBook Air it will sound okay for a few minutes and then go into the metallic robot mode where it is unlistenable. I have tried all the same things the people in this thread I mentioned. (You can find the thread by a search).

I have not seen anywhere that this issue is resolved. It is pretty disappointing to spend almost 2K on something and it not work. I have tried plenty of workarounds and not really happy with any of them. I just simply wanted to be able to have audio through the QC that I could play along with.

So the problem is well documented. Is there a solution?

I might add, that this problem is documented on both Windows and Mac computers.

1 Like

i think he is not using interfaces, he is plugging QC directly with usb, since it´s meant to work as an audio interface.
That´s how I use it in a windows pc and have had no issue

1 Like

OK. I must be tired. Thank you for pointing that out, @Cheems.
I never used QC as audio interface, as I run everything at 96 kHz.

1 Like

I had this some months ago (on Windows). The sound regularly went into robot mode within a few minutes while recording a track.

In my case the source of the problem was the USB hub I was using.
When I plugged directly into the PC (and even with a different USB hub) the problem was gone.

Thanks for sharing and I am glad you found a solution. In my case I am not using any other device. Just the supplied USB cord from my computer to the QC. It remains a mystery to me what it is.

happens to all of us my friend have a nice day

1 Like

i just had some “robot noises” yesterday, one of my output cables was getting hit by my guitar cord and sometimes when i moved i guess it caused some noise. it´s always worth checking every input/output cable and if it still won´t work then write directly to support since it might be an issue with the input port in your unit or something to do with the software compatibility - whichever way something that should be escalated to support

1 Like

Hello, I’m in exactly the same situation, and I can’t find a solution. All the drivers are up to date but the sound becomes randomly reboots. has anyone found a solution? thanks

Remove P2P torrents client.
It isn’t a joke.

They often have control on USB ports.

In past this was my panacea.