Weird noises with quad cortex as an audio interface

CorOS Version: 2.0.3

Describe your issue:
When I try to use the Quad cortex as the audio interface with my MacBook (2015) and logic, I get weird, distorted and robotic sounds during the playback that make it unusable.

Steps to reproduce your issue:

  1. Open logic on my mac book pro
  2. Select quad cortex as the audio interface
  3. Record a track normally and when I playback what I have recorded it is interfered with distorted, robotic weird sounds. If I record the wet and de DI signal with reamping purposes, both tracks ate affected with the weird sounds.

If I restart the quad cortex it works fine again but after a few seconds the weird sounds start again…

This is underwhelming because I’ve seen a closed topic about this dated on 2021… And I get a quad Cortex on 2023 and the issue is still here!!!

I expected this to happen:
When I use the QC as an audio interface I expect it to work fine just like my focusritte Scarlett do.

I have tried the following things:

  • I have tried to change the USB cable
  • I have tried all the USB ports
  • I have tried to change the buffer settings

I have had the same issue and gave up on using the QC as an audio interface. I wish I had some advice to give you but I do not. It is pretty frustrating. I am writing on a new MacBook Air which I have never hooked up to the QC yet. If I find it works without the issue I will share it here. I do believe it is a certain combination of the specific hardware in both the Mac and the QC that causes it, but I have no idea of why. I hope someone that really knows about this can help.


I had the same issue with my 2012 rMBP, and a mate’s 2013 rMBP.

Under diagnostics, I noticed that one or two of the USB numbers were suddenly going off the rails, coinciding with the glitching starting. I’ll paste below part of what I emailed to Neural;

USBAudioOutRdWrDistance Average - When working normally this hovers around 350-400, number stays white. When the problem happens, it drops to ~170, or spikes to ~600, flashing red.

The 4 diagnostics below that one also start shooting up in number when the glitching starts - adding hundreds per second to each.


I started troubleshooting with them, but I was away from home at the time/then it was christmas. When I got home, I don’t need it as an interface, so just kinda forgot about it. Last thing I heard, they recommended minimum macOS 10.14 Mojave. I was on 10.11, mate’s on 10.12.

I now have a 2021 MBP, and a Ugreen USB B to C cable. I’ve tested it for a few hours, and haven’t seen it happen yet, but it was intermittent before - sometimes working fine for several days - so there’s a chance I just haven’t tested it for long enough…

1 Like

I have this same problem with two Windows 11 PC’s running Pro Tools and Quad Cortex as an audio interface.

I get this robotic distorted sound on recordings randomly and when I get it, usually one Quad Cortex reboot solves the problem for the rest of the playing session.

This is a bit sad because I’m using QC as my main audio interface to record vocals and guitars. Never had any issues like this with other audio interfaces. Doesn’t feel like a quality product when you have to reboot it randomly to get it work properly…


The important thing for me is:
It seems to be an issue with some computers and not a problem with some quad cortex units being defective???
I mean… I have 30 days money back and I don’t know if I should return my unit and try another one…
But according to what I have read it seems to be an issue with my computer and not with the Quad cortex???

For what it’s worth, I spent a good chunk of this weekend using my previously glitchy unit as an interface with my new laptop, and no problems yet, so perhaps it was a computer problem rather than a QC problem…

You have a 2 year warranty with NDSP anyway, so don’t fret.

Thank you so much for the info!!! Is really good to know that!

1 Like

No worries. What version OS are you using, out of interest?

10.12.6 (sierra)

Ah, yeah you might find that’s the issue. Neural told me the only really support 10.14 and onwards.

Just yesterday, I used the QC for the first time as an audio interface with Pro Tools on an older iMac at SAE. Everything went smoothly, and I was able to monitor sound from YouTube while playing my guitar. I also tested recording, and it worked fine during the 7-hour session. However, it’s essential to ensure that your DAW is set to 48kHz (which is what the QC uses) instead of 44. Any clock discrepancies between the DAW and interface can cause digital clicks and pops.

As someone else just mentioned, there might be compatibility issues between certain Mac systems and specific DAWs when using the QC audio interface.

1 Like

I also encountered this issue. Monitor from QC is OK, but recorded sound in Logic is distorted/robotic sound.

  • This issue started happening after upgraded to CoreOS 2.0.3. AFAIK, it didn’t happen in 2.0.0.
  • Mac OS 12.6 (Monterery)
  • Apple M1 Max 32GB RAM
  • Logic 10.7.4

This issue can be temporarily resolved by rebooting QC. However, the same issue happens once in 1-2 days. This is quite annoying because you don’t notice it at recording phase but you notice it when you’re mixing. So you have to re-record the same take, which would be slightly different from the previous favorite take.

1 Like

It’s actually the driver with whatever computer/system you’re using. I had a lot of problems with my previous laptop and since I got a new PC I got less problems with the same issue but it happens occasionally. If you go into the QC driver window and reset it it then works normally again. It used to happen a lot more when the QC first came out and then they updated the driver but like you say it still happens occasionally. It is annoying though because it doesn’t happen with any other interface i’m aware of. You should totally log this with support though because the driver is actually outsourced so the more people who have issues, the more likely they are to get the supplier to fix it.

1 Like

I have had this issue on two PCs. Windows 10 and 11. Inclined not to blame the PC, it’s got to be a driver issue.

I’ve been having trouble with the same problem for a while, but I think I found some clues today.
It is believed to be a problem that occurs when the ASIO Buffer size is reduced to 64 samples, so it is recommended to increase the value to 128 samples.
This will be resolved by rebooting the laptop after changing the buffer Size.

1 Like

here is a trick i have used to eliminate this issue.

set PC to high performance power settings

download “powersettingsexplorer” program

run it and find the entry called like “CPU power performance timing check interval” or something

you will see that its set to 15ms for the high performance power profile.

this means that your computer will check every 15 ms to see if it needs to adjust the power settings on your PC. This can cause a massive storm of hardware interrupts, as many as 150-200k in a 12 second period. These hardware interrupt floods choke out your PC because it literally “interrupts” what its doing to do this, in my case over 170k times in a 12 second span.

I set it from 15 to 5000 ms which is the maximum.

I never have this problem again

you can run a scan using xperf to see how many it generates and how many it generates afterwards

i was at 176k, and after this settings i do about 4k instead of 176k. There are other settings I could do to decrease this down to 1%, but im not bothering because getting it down to 4k from 176k seems to have done the trick

as a side note, i have noticed a lot of stuff loads faster now too.

Here is a video explaining the entire thing.

I don’t know if this will help but here goes, I use my old Safire pro 24 as my interface out put , and the quad cortex as the input , because I wanted to control the monitors with the volume knob on the interface and also the headphone volume level, try it and see if it works ?

So why does it come by default set to 15 if the latency is drastically improved from this?

why ask why, its microsoft. why do they steal your email acct login info and all your email after they force install outlook in the recent update?