Looper won't stay in time with external clock

Hi all,

I’m trying to use the Cortex looper and am syncing it to my BeatBuddy drum pedal.

I have quite a bit of experience with midi sync with loopers as I have a Boss RC-500 looper that syncs perfectly with the beatbuddy.

The problem is that the loop ‘drifts’ after going around a couple of times. There is also considerable problem getting it to sync to the beat to start with.

At first I thought that this was a problem with using an external midi controller to trigger the looper, but I put the QC on the floor and no change.

Then I checked that the QC is receiving midi clock properly by setting a delay to sync to tempo and it works fine. i.e. if I change tempo on the beatbuddy, the delay repeats change time to match.

I have tried it with quantize both on and off (off shouldn’t work, but trying anything at the moment).

Has anyone else had any success with it working?

Also, not sure if it is related, but when my QC is receiving midi clock (all the time) the tap tempo footswitch does not function.

I have a similar issue. I am using ableton and I can get ableton to send midi clock to the QC but I have to manually set it. Not sure why it is not getting read by the QC. If I set it manually they do sync. Ideas? Going usb over midi.

That’s interesting.

What do you mean by ‘set it manually’?

Are you able to change the delay repeats if you adjust tempo on ableton?

1 Like

Actually got it. Must have missed the midi out setting in Ableton for the Quad. Works good. Can stop and start a loop in Ableton and keep the Quad loop going and bring it back in mo problem.

I’m glad it works for you.

I’m still frustrated here. I might have to go back to basics and go through all of the settings on my midi setup.

What are you struggling with? How are you trying to get it sync’d. It was pretty straightforward once I knew where to look.

I’m having the same problem. I’m using a drum loop in GarageBand with Send MIDI Clock on. On the QC the Quantize is set to 4 beats and the MIDI Clock Start is on. The QC seems to be receiving the clock correctly (for example, if I start recording on beats 2, 3 or 4 it goes into “Armed” status and waits until the next beat 1 to start the loop). But my recorded QC loop drifts from the GarageBand drum loop and gets earlier and earlier with each loop cycle.

I have sent a bug video through to neural support, but they have never really got back to me.

I’m hopeful that there will be a fix in a future update, but for the time being I’ve been using a looper on my ipad called ‘QuantiLoop’ which has way better functionality than the quad cortex looper and can be controlled by my morningstar foot controller.

I might do a video on it as it’s a pretty good alternative to a hardware looper.

Thanks for your reply and tip on QuantiLoop since I’m also using an iPad. I’ll check it out. A bit disappointing they haven’t fixed it yet … I’ll reach out to them too.

I have no issues with the looper sync in the QC. Things to check is to make sure each beat clock is set the same. I like to set mine to one beat. It is the most reliable because it does not give any device time to drift. Quat on of course. If the sync is not working and you see the tempo knob on the QC moving in tandem with your track tempo then I am guessing it is an external “follow” setting outside of the QC. I integrate with Ableton all the time and it works perfectly.

Tempo knob on QC is indicating it is syncing to GarageBand (as soon as I start the track, the tempo light goes from green to blue and slows considerably to the tempo set on the track). Very helpful to know you aren’t having problems with Ableton. I’ll try another DAW on MacOS instead of GB on iOS. Thanks for taking time to post your experience with it.

Okay, the problem is something to do with GarageBand for iOS. Works fine on Logic for MacOS. Thanks again Bruce for your helpful post.

Sure thing. It most likely is a setting in Garage Band.

Check this out to see if it helps.

I do have the Send MIDI Clock on in GB as the video instructs. And, again, that definitely is changing the Tempo on the QC. I’ve reset the tempo on GB higher and lower, and it will reset the tempo on the QC to be very close to it, but there is always a small drift.

Hmmm weird. I know with fractal the way the midi clock works it does not connect right away and therefore patch to patch it can (but not always) cause drift. Are you going midi over USB?

Yes, MIDI over USB. The tempo is sent when I start playing the track on GB, and stops sending the tempo when I stop the track. For example, the tempo LED on the QC will be blinking green rapidly, and then when I start playing a slow tempo track on GB the LED will turn blue and blink at the lower tempo.s. As soon as I stop playing the track, the tempo LED on the QC goes back to rapidly blinking green.

Def a GB issue. MAybe contact apple support but my guess is they will know exactly the issue. I am not sure of the reliability of GB but it still should transmit midi correctly. The QC is fairly reliable as I have had no issues with sync. Lot os times it depends on how open the midi transfer is. As I mentioned I run into to sync issues with the AF because their code is not open…