Latency with using plugins that wasn't there before


so pretty much when I talk to people on discord I just unplug my headphones from my focusrite scarlett solo and plug straight into my pc and use my headset mic, but I tried to see if I could use this other standalone mic I had instead of switching, and this caused me to change my audio devices in windows and everything. It didn’t work so I switched everything back to how it was before and when I loaded up archetype tim henson and amplitube 5 in Reaper there was a lotta latency which wasn’t there literally 10 minutes before, same with amplitube, but when I ran them standalone it was fine, but I just installed parallax today and when I run it standalone or in a DAW there’s latency, but all of my other plugins are fine standalone.

I have done everything people have suggested in other forums, my sound card is set to the focusrite scarlett, and it’s on asio4all, I reinstalled the asio driver, and went through all the sample rates and buffer sizes, I have also updated my focusrite control software, and my input and output settings match. So now I don’t know what to do, I deleted all other active plugins on the track I was using and used them one at a time and the latency was still there.

You really should not not be using ASIO4ALL with the Scarlett, it has native ASIO drivers. You don’t say what version of Windows or what type of computer. My suggestion would be to uninstall ASIO4ALL and Scarlett driver application. Disable all remaining audio drivers from Device Manager. Open device manager and look for “Sound, video and game controllers”. Reboot and reinstall the Scarlett drivers. Ideally the Scarlett drivers should be the only active drivers in device manager. If this works you can reenable other drivers one at a time, reboot and test again.