Lane Output level changes don't recognized as preset change

CorOS Version: 1.1.0

Describe your issue:
The values set in the lane output box are saved with the presets but aren’t recognized as a parameter change (no asterisk showing, not undoable).

Steps to reproduce your issue:

  1. Long-press the output box to open output parameter window.
  2. Change any parameter.
  3. No asterisk showing
    4A: If preset is saved, the output parameters are saved (expected)
    4B: If the preset is reloaded, the changed parameters reverts (expected)
    4C: Undo does not recognize the parameter changes and “jumps” to any previous change done.

I expected this to happen:
When I change the output parameters, an asterisk should indicate the change and should be undoable.

I don’t have the same results.
I have a preset that is currently set to multi-out, as soon as I change to (ex.) OUT1/2 etc., I get an asterisk.
If I save, the OUT1/2 sticks with no issues.

In addition, as soon as I change to OUT1/2, my undo is available etc. Also on CorOS Version: 1.1.0

1 Like

Thanks for checking it out! The glitch persists with my QC. Made a vid of it over at Discord. If I go from preset X to Y (factory or user the same) and change the output level I get no asterisk. If I close the dialog and return to it, still no asterisk. If I save the preset the change is saved.

If I after the output change in preset Y (and not saving) press Undo, QC jumps to directly back to preset X. If I then press Redo, the QC jumps to preset Y, NOW showing an asterisk and italics, with the modified output setting!

Totally weird. Have you reset your QC (just curious)? I just don’t get that behavior etc.

Hey @hasse_fx. Just letting you know that we received your video and we’re currently checking what could be causing that behavior. Thanks!

Hello, thats’s good to hear!

Regarding your other question:

Does this happen regardless of the preset you’re using?

As far as I can see, yes, same both for factory and user presets. Also it happens only with parameters that I access by long-pressing the output boxes (level, pan for analog, USB, sends, next row, stereo and mono alike). If I change the output to another typ, the QC acts normal (showing italics/asterisk.

I’ve not tried to do factory reset or anything such.

Cheers /HasseFX