Issue on Start Up after 2.1 Update

yes, these machines are computers and they are very difficult to stabilize…dont expect this kind of issues go away any soon.

people using it live should not update as soon the update comes out. you should wait at least a couple of months and see the costumers feedback

the issue here is that I dont know if QC lets you choose the version you want to update… if it doesnt then you cant wait too much because you might get a newer update

Yeah, I feel you! The QC sounds way better to me than both of those units. There’s really only a few amps I like on the Helix, but can dial in way more on the QC that I like.

Yeah as a good rule of thumb I typically wait about a week and monitor the server for any potential issues other are running into that may put me in a rough spot on a gig before updating. However, that is far from a foolproof solution, as we see here.

But that is the importance of making a backup before updating as well.

It just happened to me again, like right now, I just booted my QC and I got a black screen. Unplugged and plugged back, and it works. I think there is a problem sometimes in the init of the graphics controller.

Happened to me this weekend at the Soundcheck, too
Then after booting the first time at home, trying to figure out was wrong.

I contacted support and they had me do a factory restore, after several restarts it solved the issue. Make sure you backup any changes you made to the cloud first.

And I’ll mention a factory restore doesn’t delete all the updates.

Just got the black screen again right now powering up the QC…I’ll do a factory reset and see if it helps.
That is the 2nd in 2 days :stuck_out_tongue:

It definitely worked for me, after the restore it took a few restarts for it to fully take effect.

This happens on my QC every time I boot it up. I have to turn the power off, then back on the get it to boot up. I contacted @ndsp_staff support… there reply was let us know if it gets worse… WTF… that was two weeks ago… I contacted them again today and waiting on a reply… it’s an expensive product… it ‘’not turning on’ seems like a big issue… Great Custer support Neural DSP…

Most QC users have reported a fairly positive support experience. Wonder if they have fixes coming soon and were hoping for you to hold out until then?

You could try a backup and factory reset, drag that it may be. The editor is supposed to drop by October 9th, or sooner according to Neural’s August development update. That will mean a new firmware as well. Might want to wait for that and see if it fixes your startup issue. Unless your warranty is about to run out, that will probably be quicker than, for example, sending it in for repair, which wouldn’t make sense anyway, if it is a firmware problem.

I have also contacted Neural DSP Support about this issue. I was told:

"We’ve now had several instances of this issue reported, and the developers are treating it as a high priority. The cause is as yet unknown but it’s highly likely it’s an issue in the software, so any fix will hopefully be addressed in the next or future update.

Let me know if the issue continues, gets worse, or makes the unit unusable."

Having read Norseman’s posts, I did a complete backup, factory reset, and restore from backup. Still, I get the grey screen about every second time I try to boot up.

I hope a fix is coming soon.


I received that exact same reply initially, I have followed up again with @ndsp_staff but no reply. I feel that, let us know if it gets worse is a pretty terrible response… there product simply not turning on feel like a pretty big problem for users.

I have tried the reset with no success… agree sending to them for a software issue is a waste of time… I need the unit to simply turn on and weekly gigging with it is a concern as it’s the skills that pay the bills. Should have bought a Fractal FM9. @ndsp_staff

Just received this from NDSP:

Hi Justin,

This black screen on boot issue is addressed in the next CorOS update, which has already been released to beta testers. We hope to release it early next week if no other major issues are found.

Thanks for your patience

Best regards,
Neural DSP Support Team

Let see……


I switched to using a Cioks DC7 at the same time I updated the firmware, and ever since this started happening to me too. Almost every time I power on, I have gray screen and need to restart. Though so far, it will boot on second try 100% of the time.

I was worried it was the Cioks causing the issue, but then I was able to replicate the problem immediately using the original PSU. Which eliminated my concern that I had just blown $350 on a power solution that might fry the QC.

Glad to see it’s been acknowledged and a fix will be in the next update.

1 Like

I had this happen just once so far, yesterday.
Looking forward to the next firmware release!

I am following up on my own post. This issue has NOT reoccurred for me since updating my firmware to 2.2.0. Thank you, Neural DSP!

1 Like

I’ve had the QC for 2 weeks now. Worked fine. I upgraded to CorOS: 2.2.1 two days ago. Now I get a gray screen. It gets worse every time I reboot. I rebooted multiple times, unplugged the power, did a factory reset. Is there a way to go back to CorOS: 2.1?

Thankfully Cortex Controls works.

Did you get this resolved? I am having the same issue but my gray screen still persists.