Issue on Start Up after 2.1 Update

CorOS Version: 2.1.0

Describe your issue:
When powering on the QC after the new update I am frequently getting a blank dark grey screen with no lights on the buttons until I unplug the power and replug it in. It has been fine after that, but certainly scares me when I show up to a gig with a grey screen.

Steps to reproduce your issue:

  1. Step 1 - Plug in power cable

I expected this to happen:
I expect to see my preset and lights on the buttons

I have tried the following things:

  • Not sure what I can try to fix a start-up issue

Hey @brodyfraziermusic - Thanks for dropping in! E-mail our support team on

This has happened once to me since updating. It’s been ok since that one time.

1 Like

I also got this once today. Power cycling fixed it and it booted as normal though.

1 Like

I am also seeing this issue since 2.1

Have any of you tried v2.1.1 yet? If so, does this problem persist?

I have not updated to 2.1.1 yet, had a gig today I was worried about messing it up for. Will try to update after this weekend.

Very shortly after updating to CorOS 2.1.0 I encountered this issue. But it only happened once. I updated to CorOS 2.1.1. without any problems so far.

Just had the same issue today for the first time, right after updating to 2.1.1

I am also getting this issue after updating to 2.1.1.

It seems that every second boot attempts gives rise to the grey screen. After power cycling again, I seem to be able to boot up.

I haven’t run into the issue again since I made this post, but I haven’t changed anything about my setup. Support did reach out, so kudos to them for customer service.

I face the same issue having the last software version installed.

I also had this, but only once.

happened to me once so far as well

It happened to me once when I updated to 2.1.0. Now I have 2.1.1, rehearsed and played 2 gigs since, it did not happen again.

It’s happened to me a few times since updating

Ive had it happen twice. It only happened when starting the unit in the morning after shutting down at night while leaving plugged in. Ive been unplugging my qc nightly since it happned the 2nd to avoid it.

This has happened to me twice too – once during a sound check that nearly caused a panic attack. Thankfully, unplugging the power cable and plugging back in did the trick, but it does make me worry that something else is going on.

Really bummed Neural hasn’t sorted these start up issues with the QC. I’ve seen it on my first QC and a friends recently. Had both Kemper and Helix equipment for years now with great reliability, but had issues with a QC within a month of owning a new one……

I have had a Helix Rack for many years, it too had its software issues sometimes :wink: Plus, the sound doesn’t get close to what you get with the QC.