Fortin NTS 2.0.0

[2.0.0] – November 29th 2019 – To ensure a setup without problems, we recommend to make a clean install of this software. Please uninstall the previous version before installing this update.

Added

– AUTO DEMO was implemented. Trials no longer need an activation code to be activated.
– BUILT-IN TUNER is now available in both versions, plug-in and standalone.
– The standalone version received MIDI SUPPORT. Now you can assign MIDI commands to control plug-in parameters, UI components, and presets files.

Changed

– STEREO MODE #1: Stereo Switch now pans the microphones internally as dual instance.
– STEREO MODE #2: To ensure retro-compatibility with old audio sessions, we didn’t add volume compensation when you turn on both microphones at the cab section.
– ZUUL algorithm was redesigned to be more accurate to the physical unit.

Fixed

– Multiple bugs are now fixed to improve stability, graphic performance, and audio issues.
– Black-Screen GUI (FIXED)

If you experience any bugs, errors or crashes, please contact our support team at support@neuraldsp.com.

1 Like

This doesn’t work. After install it asks for the license for the nameless bundle, not the nts bundle. I’m now completely locked out of using the product, despite having a license which worked up until downloading version 2 today.

Did you do a clean install? If so, please email support@neuraldsp.com so they can resolve this for you.

I have talked to your live chat. They said “We have an issue here, we will update the installer” and then closed the live chat. No “sorry”, no explanation. Support have not replied to my email.

And yes, I did a clean install after uninstalling version 1.

Hello My NTS works on standalone but Garageband wont let me use it. I did a clean install twice already still the same thing.

Hello @villaloboseddie1. Make sure you have the latest version of iLok License Manager installed on your computer. After that, allow Garage Band to use 3rd party AU, ticking the option from preferences. Please, consider that the new versions of the plug-ins have compatibility issues with Garageband and MacOS BETA updates.

Check our DAW compatibility list right here: https://neuraldsp.com/faq/

Meanwhile, you can always roll back to a previous version of the plug-in or try another DAW.

Thanks for the free update. I really dig also the new factory presets added in V2.

Hi, I have heavy CPU problems since the release of the 2.0.0. I tried both stay the first version and the new one, but NTS became real heavy on CPU, and I don’t have the same issue with my other Neural DSP plugins. I tried to contact on several occasions the assistance, and I was replied that there will be updates to fix this bug. Unfortunately, I’m waiting, and I can’t use NTS since the release of the new version. I’m desperate, is there any solution to my problem. Many thanks.

Hello @bertonjeremie. We have received reports regarding the VST3 version of NTS, especially in Reaper. This will be fixed with an upcoming update.

Do you experience the same issue with the Standalone and VST2?

Hi,
In Reaper, Win10, i run into some issue(s).
It seems that Custom IRs are not loading in properly. (NTS, 2.0.0)
I added custom IRs; it caused the plugin to start glitching. Like the computer is struggling with loading in a new IR (same project, setup, IRs with Nameless 3.0.1 works fine, can switch back and forth the same IRs with no problems).
Also, when i try to chose from saved presets with custom IRs from the drop down menu, it does load the same IRs every time, even though i saved multiple version with multiple IRs.
Standalone works fine, happened only within DAW (Reaper, Win10).

Has anyone experienced same/similar issues?

Hi @GsR-Theta. Do you have the same issues with both VST2 and VST3?

I’ve just tested it. Happens only with VST3.
After i reloaded the project, VST3 seemed working fine, but it starts to glitch after a few seconds of playback. Happened not just during switching presets, but also during adjusting ‘middle’ on the amp…

Regular VST seems working fine. Thanks for the tip.

1 Like

Any progress on this issue? VST3 version still crackles heavily in Reaper with 128 buffer size.