NTS VST3 not working in Reaper

I have uninstalled the NTS suite and downloaded and installed the latest version. The standard VST works fine as does the stand-alone but the VST3 does not work. It does open in Reaper but only makes horrible distorted sounds. If I try to use the tuner it does not even see input from my guitar but if I pick any notes or chords I only noise. I did uninstall and re-install again with the same outcome. Is anyone else having issues with the VST3 installation? I also use Nameless and that VST3 works fine. I am using 64-bit Windows 10. I also am using the latest version of Reaper.

3 Likes

Hello, @mike.miranda. Some users have experienced compatibility issues with the latest update of NTS VST3 and Reaper. Our development team has already fixed this and updates will be out soon. Meanwhile, you can use the VST version.

Apologies for any inconvenience caused.

Sounds good! Thanks for the fast response and Happy New Year!

1 Like

im currently having the same issue. the plugin works perfectly on its own but the vst3 doesnt work in reaper. just a bunch of noise when you play.

1 Like

Hi @michael.clester. I’m sorry for the inconvenience.

The update for NTS is currently on beta test. Meanwhile, you can use the VST2 version, it should work perfectly fine in Reaper.

I’m still seeing the same issue, any idea when this is going to be addressed?

2 Likes

Hi!

Having the exact same problem, on trial v2.0.0, Reaper v6.12c

Can’t make the VST work, this is very frustrating…

1 Like

Hi @jeromesnail. The VST2 version (VST in Reaper) should work just fine. Are you able to find it on the FX list?

Hi!

No, only VST3 available. Yet during the install of the NTS plugin I choose the default install.

1 Like

@jeromesnail Open Reaper, go to Options > Preferences > VST, and press Clear cache/re-scan. Apply/ok and restart Reaper.

If that doesn’t work, close Reaper, uninstall the Plug-In and reinstall it with the exception of adding a subfolder containing it (example: C:\Program Files\VSTPlugins\ NTS). Re-scan your Plug-Ins and check if the issue persists.

1 Like

I’d try that and keep you informed.
Thanks!

Ok it worked, I had to tell reaper where was the VST plugin.
Still wish VST3 worked ou of the box though…

1 Like

Hi People ! I just solved the problem , Vst3 is not or rarely compatible with Reaper that gives those horrible distorted crashes sounds , so i had to go in my hard drive , finding nts dll exe , doing copy/ paste , going in vst , paste next to Nolly vst , after that i re-opened Reaper at least Nts appeared in vst plugins list and then that worked , i am very happy , conclusion: vst3 gives problems in Reaper , and you should select as Vst to make it work

Not true. All my other VST3s work perfectly in Reaper, including FabFilter, Toontrack, Native Instruments, Waves, Stillwell, Softube products. Even the other Neural DSP amp sims work just fine in VST3.

My suspicion is that something about the NTS architecture is bugged and the problem is mostly hidden on VST2, and gets way worse on VST3.

Using VST2 format only partly alleviates the NTS crackling problem. If I use Stereo mode and low enough buffer size, NTS crackles. It distorts the audio stream of the entire computer, not just what the DAW is playing.

I have to raise the buffer size higher than what I use with other Neural amps, or avoid Stereo mode which is not really a satisfying solution. And that’s with VST2. With VST3, I can’t do anything. Even 2048 buffer doesn’t help, stereo or mono.

Edit:
@Gonzalo When is the update coming?

That was over a year ago.