Failed to use the toe switch (out 2) of Mission Engineering Expression Pedal?

Hey guys, the expression pedal I use is EP-25-PRO AERO. It was connected with decent TRS cables (OUT 1 to EXP 1 and OUT 2 to EXP 2 of QC). The recalibration of the pedal (OUT 1) went well, it went from 0 to 100 when the pedal went up and down. But the recalibration of the toe switch (OUT 2) didn’t show expected result, which should be like 3:49 in this video:

In my case, the result was exactly the same when I was recalibrating OUT 1. The parameter went from 0 to 100 when the pedal went up and down. And there is no difference shown when I engaged or disengaged the toe switch.

I thought maybe there’s a bug or something with the recalibration and tried to go directly to the expression pedal assignation. I tried to assign EXP 2 to turn the compressor on and off and had already chosen the “Switch” option. It turned out that the toe switch doesn’t work either. But the compressor do turn on and off when the pedal goes up and down, which is just the same when choosing “Heel-Toe”.

I haven’t seen any videos on Youtube about testing EP-25-PRO AERO with QC, but I’ve seen plenty of videos using SP-1. So I’m not sure if there is some kind of compatibility problem between QC and EP-25-PRO AERO. But I suppose it shouldn’t be the case as EP-25-PRO AERO and SP-1 are made by the same manufacturer.

Anyone has idea about this?

I’m not familiar with the EP-25-PRO AERO EXP but I have seen EXP’s wired differently between various models. Worst case, email and they will get you sorted quickly.

I never had to calibrate the toe switch for XP2 on my Mission SP1 pedal. It just worked automatically.

I believe some pedals may be wired backwards from how the Mission is setup. I’ve seen some users DIY rewire their pedals to match what the QC needs, but I’m afraid I don’t know the technicalities there.

I have a preset on the cloud which is a template incorporating XP assignments for the MIssion SP1, that allows you to invert bypasses between blocks with the footswitch.
You’re welcome to try it and see if it works with the pedal. If it doesn’t it may be that your pedal hardware is configured differently and would need to be modified.

If it’s just particular settings giving you trouble, this preset ought to sort it out:

Are you using TRS cables for both connections per the video’s instructions? Have you tried swapping the cables to make sure you don’t have a bad one? Btw, for incompatible expression pedals, sometimes you can get things working by modifying the cable rather than the pedal. At least on other modelers.

ah, that reminds me (I should have thought of it before) -

the behavior described is what might happen if the cables are reversed. Might want to check that too

I’ve tried swapping them. Still don’t work.

This may sound silly, but I had some trouble with the toe switch on the SP1 not working. After troubleshooting I just realised that you really have to step on it quite hard to actually press the switch. So, uhhh… Step on it really hard and see what happens? :person_shrugging:

1 Like