Expression position still not correct in 2.2.1 on patch load

CorOS Version: 2.2.1

Describe your issue:
Loading a patch gets the wrong value of Exp1 position, causing for example a Wah that is configured to use Exp1 for position and bypass to load in the wrong state on patch load.

Steps to reproduce your issue:

  1. Configure Wah to use Exp1 for position and heel-toe inverted for bypass
  2. Save the patch with Exp1 set at 100% (toe down) and the Wah bypassed.
  3. Don’t move Exp1 and load the patch, the Wah is incorrectly turned on, the patch appears dirty, and the Exp1 position is at 90%, not the 100% the patch was saved at, or the current position of the Exp pedal.

I expected this to happen:
I expect either the patch to load with the saved values, i.e., Exp1 at 100%, or if Exp1 position is read on patch load, that the value is the correctly corresponds to the Exp1 position.

I have tried the following things:

  • I have tried reconfiguring the Wah expression assignments
  • I have tried Changing the Wah position min and max range. Setting the max range for example at 90%, the position read at 87% on patch load, still too low to bypass the Wah.
  • I have tried Unplug Exp1, and load the patch, the Wha is now correctly off and the position is correctly at 100% where it was saved.

Having this same issue. It no longer goes to 0 after a few preset switches as it did before 2.2.1, but Expression pedal 1 is still being read at 90% when switching patches. I’ve tried recalibrating the pedal, replacing the volume blocks, switching to gain blocks, all to get the same result.

Same here. After every Preset Load Utility Gain is set to -1.3 db and Utility Volume to 91.8%.
Moving the pedal reset it to normal (0db or 100%).

@NDSP, when loading a patch and reading the expression pedal position, are you considering the calibration values for scaling the position?

1 Like

Same here…

And same. After switching presets, volume block set to 91.0%. Even if I rock pedal to 100%, tap the three dots to the left of the block name, and tap ‘set parameters as defaults’ it immediately resets to 91.0%.

I’m having same kind of issues. Last bug was all sorted when I touched the pedal now there is sudden freezes when moving the pedal. Last gig the position got stuck several times to a random value. Moving it up or down didn’t do anything for couple of seconds. This is really bad and unfortunately makes it unusable as it is right now. This is really bad news while being in the middle of a tour…

I have never seen that. Check your connections.

Checked connections, tried different pedals and cables. Started right after the update.

CoreOS 2.2.2 was released this morning, can you please confirm this bug is squashed?

Mine seems work perfectly now! Will report back after couple of shows. Thanks for quick update :slight_smile:

1 Like

Bug is resolved. Note that some patches may still load as dirty because the expression pedal position changed from what was saved.

1 Like

Bug is squashed on my end

1 Like

Thanks for the feedback everyone! I’ll keep this open for a few more days.