Experiencing pops/clicks on all Neural DSP software after Windows 10 reinstall

Here is a list of various relevant details…

  • Issue occurs on the stand-alone software for Plini, Nolly, Omega, NTS, Abasi, and Cali. Issue doesn’t occur if using the amps as VST plugins through FL Studio 20.
  • My PC is an i9-9900k and 16GB DDR4 RAM, so my hardware should be more than sufficient
  • My interface is a Scarlett Solo 3rd Gen. I’ve tested it in all USB ports and the issue persists regardless. Tried different cable as well. Also uninstalled and reinstalled all relevant drivers (USB and Focusrite Control software) multiple times.
  • DPC Latency reports that my latency isn’t an issue
  • Issue occurs on any buffer size (greatest, lowest, or anything inbetween), and happens across 48khz-192khz, so basically occurs regardless of whatever setting used.
  • Setting the amp’s processor priority to “High” doesn’t help.

It’s perplexing because everything worked up until I re-installed Windows 10 a few months ago. I made sure to go to the website and re-download the software and install it normally, rather than trying to use a backup. Why would the amps would just fine in FL Studio, but have issues in the stand-alone software? Why did the software work without issue before, but doesn’t work on a newer Windows 10 install?

1 Like

Few things I can think of:

  • Verify that you have only 1 input enabled at the audio settings.
  • Make sure that your audio interface is the only device enabled at the sound settings of the control panel.
  • Uncheck/Disable “Exclusive mode” in the sound settings of the control panel (How-to).
  • Experiment switching between 44.1 and 48 kHz, making sure that the same sample rate is shared between the audio settings of the application and the sound settings of the control panel.

Fresh Windows installations can be quite cluttered with processes that affect the real-time performance of your system. If you still haven’t optimized it, check this guide.

I have had similar issues after a win10 install.
as above, i would suggest to make sure in the settings you have your Audio Interface choosen, make sure it runs as ASIO and not as a Windows;
make sure you only enable the input you are using, and disable any other inputs.

another thing which was causing me trouble is my N-Vidia graphics Card settings. I know this should not be an issue but it was. Somehow the CPU was adjusting things for the GPU in the background and this caused some issues.
Make sure you set the “power management mode” settings to “Prefer Maximum Performance”. That helped me.

1 Like