Can't Save Presets

Not sure if this is an issue from the new firmware.
I create a new preset and go to the three dots and “save as” is greyed out. I go to the regular “Save” icon and it takes me to naming the preset. I type in the new name and next button does not work. I can hit the save icon “that looks like a disc” and it takes me to the screen that says “Guitar” or “Bass” or “Synth” etc. and can’t do anything from there either, I am not sure if I am missing something really simple or what. Before the firmware update, I created a ton of presets with no problem. I have never had the “Save As” button greyed out. If it is any help, the edit detils button is greyed out. I even tried taking another preset and moving it, which I can do. But then I can’t rename it. Help?

Are you trying to edit the factory presets in the factory preset folder? If so, you can’t do that. You have to make your own presets folder.

No. I have not tried to edit the factory presets.I did however figure out the issue. A preset names seems to need at least four letters. I was setting up a new preset and was using an EVH amp model. For expediency sake, I named the preset EVH and I could not save it. I accidentally called it EVH 1 and it worked. I went back and tried naming presets TTT or any random 3 letters and it didn’t work. I add a fourth letter and it is fine. That may be in the manual or not. None of the tutorials mentioned this phenomenon. Live and learn…