Bypass function doesn't work on several reverb types when trails turned off

CorOS Version: 2.0

Describe your issue:
No sound passes through the signal chain, when I bypass the reverb with mix on 100% and trails turned off.

Reverb types with issue:

  • Room
  • Shimmer
  • Spring (M/ST)

The three Plate Reverbs are working as expected.

Steps to reproduce your issue:
Use one of the affected reverb blocks in the signal chain (mix 100% and trails off)

I expected this to happen:
When I bypass the reverb block, I expect 100% of the signal to pass through. The mix value shouldn’t have an impact on the output, when the block is bypassed.

I have tried the following things:

  • I have tried different reverb types to see which reverb types are affected
1 Like

I noticed the exact same thing while using a Digital Delay at 100% mix on the ‘B’ lane of a splitter (to simulate a slight delay,) .

At first it drove me nuts , I double-checked everything on the splitter, blocks, etc…
In the end, I only switched the ‘Trail’ to ‘On’ and the issue was resolved.

So, it seems to be a bug in 2.0 that concerns a lot a block having ‘trail’ set to ‘off’ : the ‘Bypass’ on those blocks is considered as ‘Mute’ and mute all the remaining blocks.

Hopefully, it will be fixed in the upcoming 2.0.1 hotfix.

1 Like

@M_NDSP This bug is fixed since 2.0.1. This thread can be closed :slight_smile: