Block assignment to scene get forgoten

CorOS Version: 1.4.2

Let’s illustrate eith a chorus block. I assign the mix and depth to scene and i keep it turned off by default on all scene. I tried to assign the state on/off to scene as well. Even after saving the preset when you reload it the block state is global . What that means is if you switch to stomp and toggle it, it will change the state on all the scene.

I tried with a simple preset and its reproductible.

I noticed that as long as the block state is different for at least one scene it will save and recall properly.

Clearly a minor bug but one notheless. It creates situation where there in no work around…

Hi @StephaneP and thanks for the feedback! Please email support@neuraldsp.com with the specifics and get the bug logged into their system.

@StephaneP
Did you assign the bypass to scene mode by long pressing it until the ABCD icon appeared?

Yes, of course. The behavior has changed since 1.3.0 I think. I confirmed that is not my issue.

Regards

Sorry, just wanted to make sure, since some people did not notice the change.

Don’t worry it’s not always easy to get to the real story. I will try to make a video.

1 Like

Tested this on my QC (firmware 1.4.1 - this is the latest version) and I cannot recreate your bug. Wondering if this was an old preset from a prior firmware version that somehow is not cooperating with the new firmware? Can you recreate this bug on a preset you create from scratch now? If not, you might want to just recreate the one that is misbehaving and delete the old one. Worth logging as a possible bug with Neural and sending them the malfunctioning preset first though.

If you upload the problem preset someone else can test it.

I’m in contact with Neuraldsp support. I’ll keep the info updated.

1 Like