Audio dropouts when using only one plugin instance

Hello everyone,

I have been using Neural DSP Plini for quite some time now, mostly in standalone mode, which works perfectly, even with 16 samples buffer size.

When using the VST or VST3 plugin in Ableton 10 or FL studio 20, I often get audio glitches using only 1 plugin instance on 44.1kHz / 128 samples.
I thought that plugin is very CPU intensive so I turned off the reverb while recording as it seemed that reverb influenced the most on the crackles.

However, the last few days I’ve been trying out the Cory Wong plugin and I’ve experienced similar problems. Standalone also flawless performance, 44.1khz / 16 samples, but using it a DAW makes very strong and frequent crackles for some presets (e.g. Full Smush Lead is basically unplayable)

My PC specs are:

  • i7 7700k
  • 16GB RAM
  • 250GB main SSD

Audio interface is Scarlett 6i6 2nd gen, using the latest drivers with Focusrite control

I went through well-written optimization techniques for Windows: deleting unnecessary programs, reinstalling drivers, changing USB ports for the audio interface, disabling default audio interface in BIOS and others written in the guide. Even tried overclocking the CPU a bit, but it did not help.

I discovered that crackles are mostly caused by supped and high CPU spikes that max out the CPU. Usually, having only 1 plugin instance 44.1kHz / 128 samples keeps my CPU at 50-70 range, but every few seconds it spikes to about 99 which causes a dropout. This test is done without any other plugin active, only a single channel in Ableton with the Cory Wong plugin. But, adding another plugin instance to another channel stabilizes the CPU usage to about 50%. You can see that here. Adding up to 7 plugin instances now works pretty stable. Now only that’s stable, but increasing the number of instances on other channels somehow increases the overall stability. But, this concept does fall apart when used in a real project with other audio tracks because then it uses the required power for other tracks and stability is lowered.

Also, setting the sample rate to 96kHz and 128 samples removes glitching, which is also odd because it should require a lot more power. I could get it to 8 instances of both Plini and Cory Wong to play simultaneously in these settings.

Another thing that I tried is using Maschine MK3’s onboard audio interface at the same settings and it achieved similar results, although it was a bit more stable in Ableton. Using it in FL Studio was a lot worse than Focusrite.

Latencymon did not show any issues (as far as I can understand the reports):

Using the VST plugin on MacBook Pro with the Scarlett works without problems. 10 instances of the most intensive presets work on 44.1kHz/128samples. Its processor has about the same performance as my i7 so CPU power should not be the issue, but it does use CoreAudio drivers, which could be the main reason why it works better.

What is else there to try? Is anyone experiencing a similar issue?

Hey @atoru. Are you trying with mono instances? It is expected that CoreAudio will perform better than ASIO, but the difference shouldn’t be that much. Can you check if the CPU usage drops drastically after disabling the cab section?

Hey @Gonzalo, thanks for the quick reply!

I believe I am trying the mono instance, can you please verify that in the picture?

In the standalone version, I only use the input channel for my guitar so it’s mono processed, but settings are not visible for the VST version.

Disabling amp sim, cab sim and post effects does not make a difference on its own. Disabling all of them reduces the load significantly, but then again, there’s nothing much to process.

That’s quite strange. We’ll have to investigate this.

Please send us a ticket to including a screenshot of your LatencyMon analysis.


Hey @Gonzalo,

fortunately, there will be no need for that!

As I was running LatencyMon one last time, so I can submit my reports to your team, I monitored the processes in task manager. Latencymon did not report any anomalies.

Something weird came into my focus. I discovered a process called GCloud running and using just about 1% of CPU. That seemed odd because I disabled all of Google’s services such as Drive or similar and turned off the internet connection.

However, this was not Google related software, but a utility software for my Gigabyte motherboard. I remember I installed their own software called App Center for something I can’t remember, at least 6 months ago, maybe even more and I thought that this software is unrelated to the performance of my computer. Boy, was I wrong.

I promptly uninstalled this software which automatically, uninstalled all of its additional background services. Immediately after uninstalling this, my DAWs somehow started breathing again. I can run 10 instances of Plini or Cory Wong on 64 samples buffer size without a single dropout, and audio load never reaches over 60%. All of my projects now work multiple times better, regardless of the plugins used.

I am amazed by how much this little software caused damage and how hard it was to find. Mostly because it did not kill my PC, but it suffocated it silently and randomly. All the monitoring apps did not catch anything. It was there for months like a leech and I did not notice it. My guess is that its EasyTune interfered with the CPU and tried to optimize the performance by manually adjusting clock speed. But that was definitely brutal for audio tasks.

I hope this helps someone in the future. Real-time audio issues are sometimes super hard to debug. My advice now would be to always test performance on a completely clean machine if you can. If not, try to really strip down your software stack to the bare minimum because you never know what can interfere with audio.

All in all, I am super happy that I found this. If I hadn’t bought Cory Wong plugin, I probably wouldn’t bother with this for months, until it would start to really get on my nerves. :laughing:

Thanks NeuralDSP for the amazing plugin, sounds made on Cory Wong are seriously world-class!

1 Like

That’s great news! Thanks for letting me know. I’ll keep it in mind in case someone else reports the same in the future.

1 Like