Reverb CPU issues with PLINI and NOLLY

Hi, the plugins works fin until I put on the reverb pedal then everything starts crackling. I didn’t have this issue on my previous computer which was far less suited for recording with the Nolly Archetype.
I tried all the optimizing options you advised but nothing has changed.

I’m working with an asus laptop equiped with AMD Ryzen 5 3550H and 8gb ram.

Thanks for the great work.

Hello @reda.el_kasmi. Which DAW are you using? How much CPU does the Plug-In use per instance? What are your project settings?

I’m using Reaper,

This is the cpu usage with the reverb

And without I’m around 4%
My buffer is 128 and sample rate 44.1

Thanks for the screenshot. That doesn’t seem high enough to cause audio dropouts. Did you measure your system using Latencymon? check if there’s any driver/process causing high DPC latency.

I don’t know much about all that but everything’s in the green

Aha something else came up

Try disabling Wifi/Bluetooth momentarily and check if the issue persists.

That hasn’t changed a thing

Did you disable it in the device manager? Try to run Latencymon for about 10 mins and check the process that gives the highest execution (ms) on the Drivers tab and the highest amount of Hard pagefaults on the processes tab.

I did disable it in the device manager, The process and the drivers that ranks the highest are both named system and nt kernel system.

Unfortunately, that’s quite common with laptops. At 5.0% CPU usage inside Reaper, you shouldn’t experience any audio dropouts. If you do, the reason is almost always due to buffer underruns caused by processes/drivers giving high DPC readings. You can find several articles about these issues [1], [2].

I’m sorry about this. If you wish, you can send us an audio example of the issue to just to verify if it has something to do with the Plug-In. You can also attach some screenshots of the Latencymon analysis to confirm the high readings.

I’ll try that, thank you for your time.

1 Like