Strange glitches about USB recognition

CorOS Version: 1.0.0

Describe your issue:
I’m using a macbook pro 2015, with Big Sur. And my Quad Cortex didn’t appeared on its output/input sources. Sometimes it appeared on the OSX’s About this Mac → Support → USB session

Steps to reproduce your issue:

  1. Macbook must be powered on with its own DC adapter.
  2. Both of the DC adapters of Quad Cortex and Macbook must be plugged in a same power board I assume.

I have tried the following things:

  • Failure: reboot of both machines, SDRAM reset, changing the cable… everything not worked
  • Failure: When I used a external USB hub without any power source(neural DSP do not recommend this), my macbook recognized my Quad Cortex but there were lots of noises when I tried to record my playing.
  • Success: When I plugged out my DC adapter from my macbook, it suddenly recognized my Quad Cortex.
  • Success: When I plugged another DC-powered USB device into other side of USB socket, my Quad Cortex instantly appeared to my Macbook.

Maybe because of the electrical issues of USB port of macbook. (not appeared in my iMac 2012)
Wish to help someone who have the simillar issues.