Return inputs not working

I’ve just got a QC and I cannot get an external effects loop working. I suspect it is faulty. I have a support request in but Neural DSP haven’t got back to me after an initial reply.

I have created a very simple preset. Just one row on the Grid with amp and cab blocks plus an FX Loop block at the end of the row. Audio seems to be passing out of the send, I can see activity on the SEND 1 LEVEL meter on the I/O Settings page.

But no audio seems to be coming back in to the QC either Return 1 or 1/2 for stereo. (I have a patch cable I know to be working directly connecting Send 1to Return 1.)

I say no audio is being passed but if I turn the RET 1 LEVEL to 40 to 50dB in I/O settings then I DO hear audio but it’s extremely noisy and completely unusable!

I’d wait for a reply to my support request but have less than two days left to return the QC for a refund.

@Marsdy , when did you reach out to support? Also, most resellers offer more than a few days prior to return but have you checked your send / return mix controls?

I last heard from support on Friday.

Yes I’ve checked everything. With the FX Loop block in its default state and the Mix parameter set to 100%, no audio is passing through the Send and Returns.

I’ve tried both mono and stereo FX Loops with both TRS and TS patch cables to bridge patch directly between the Send and Return Jacks.

Last thing, are you using the OEM PS? I have heard of this occurring with alternate PS’s not providing the correct voltage/amps. Also, have you tried a preset with just the FX loop block added? If you remove the FX loop block, do you hear your amp/cab as normal? Did support have you send logs?

1 Like

OK I’m officially an idiot! :woozy_face:.

I tried the OEM PS and it works fine. I was using a Cioks Crux BUT….I had it set to 9v! Duh!!! Set to 12v that works fine too!

Thanks for your help MP_Mod. I’ll message support and tell them.

No worries! Glad we resolved it! I figured that was the issue as I have seen it more and more!