Quad Cortex Audio Glitches, drop outs, etc

I’ve become a bit impatient with the Audio Performance of this unit in Daw’s or just using this unit as an audio interface. I also have an Apollo Twin, Line 6 Helix and a Kemper and I NEVER have a single issue with them. I constantly get the strangest noises when simply recording music, youtube, gaming, anything. I have a plenty powerful enough PC for this and comparing to my other audio options I know it’s not an issue I can fix myself. It’s clearly a driver issue or I am missing something completely. What is the deal with this, seriously. It’s been a known issue since the unit was released and its January 2022 and I still have zero fun with this unit as my audio interface. It plays flawlessly hooked up to my monitors or headphones but as soon as I attempt to use it for the only reason I bought it, It frustrates me every single time. Anyone find fixes for this? I’ve tried Asio4all and it doesn’t help. Tried every buffer setting possible. Thinking about just selling it for a good price. It’s been a huge headache.

It’s a well known issue that Neural is aware of. They are currently in the latter stages of alpha testing the 1.3.0 update which will likely include a solution for this as many have this issue. I would hold on for a little while longer if you can. The new update should bring a lot more as well. It should be worth the wait. I know how frustrating this is. I hope it gets sorted soon.

1 Like

Oh, and welcome to the community :slightly_smiling_face:

1 Like

First, welcome. Sorry to hear about the issues. I’m not using mine as an interface. I have an Apollo and prefer to use it. Hopefully that and many other issues will be addressed soon.

1 Like

I suppose I’ll hold on to it for a while longer. I mean, I love the device no doubt. Just becomes super frustrating when basic features of an interface aren’t working as I and many others intended. I’ll just hold on to it and hope for the best. I’ll use the Apollo for now with Neural plugins for the time being. Appreciate the warm welcome.


Consider writing to support@neuraldsp.com. As already mentioned above, many people have this issue but you are the first one I read from who still has these issues when using Asio4All.

Did you disable safe-mode? That resolved the issue or those that have experienced it etc.

1 Like

Yes, I have. I’ve tried pretty much everything I’ve read in the forums. None if it has improved the reliability. I’ll just wait till new driver. Thank you.

Yeah. Even if it did work, I wouldn’t want to use that with a product like this. That’s an ultra generic driver and causes other issues for people as well. It’s just crazy to me a product has been out this long and doesn’t have a proper driver, that’s all. I’ll wait a little longer. Thanks for the help guys.

1 Like

I agree that the Asio4all is a workaround. I’m waiting on a proper driver before I even start interfacing. I’m happy with the QC for everything else though. I’m sure the team at NeuralDSP are bringing it. The QC is designed for it. I’m in it for the long haul

Hey guys, new QC owner here.
I got weird sound problems randomly - strange ‘compressor’ effect squashing my input signal and then glitching sound - bit crusher type of effect.
Got rid of those completely after disabling ‘MIDI over USB’ from settings, thought i’d share this, since nobody mentioned it.

I see you guys been struggling with these problems a little bit longer, so i’m a bit sceptical i got rid of audio problems with QC :grinning:

1 Like

I have totally solved (bitcruishing effect) removing bitcomet.
I know that it can be strange but when apps or another softwares have control on usb port (malicious or not) we can have these problem and not only with qc… Headrush the same for example.
I know this on bitcomet in my specific case. Removed and my units are solid rocks.
I hope this can be helpfully for anyone

I’ve been there with the macOS driver and felt the same. I kept reporting to neural support and helped them with Alpha testing when fixes came through. With the last FW version, the glitches are none existent on macOS. I think Neural is aware of issues on windows and hopefully, come up with a stable fix soon.

I’ve had the exact same experience as you with windows and I emailed NDSP about it around two weeks ago out of frustration. A lot of it is around the driver which is basically supplied by another vendor so they’re kind of on their time as to when it is fixed or they’ve “raised the issue with them”. That was the general gist I got from it.

In relation to ASIO4ALL I also get better, but similar results. I think ASIO4ALL still borrows components from the Neural Driver so it also bit crushes at lower buffer sizes. Otherwise the issue is to do with the unit itself, not really sure. I must say I am disappointed at how long this is taking to fix as it becomes such a hassle to use it for recording (basically DIs can’t be tracked).

Another thing that grated me was having this issue for so long and then they bring out yet another beautiful plugin into the world. Seems like often the QC users are second fiddle to their plugins. Anyways, will hopefully get sorted soon. If it isn’t fixed in the next update I’m getting rid of mine for sure.

Thanks. I’ll try this one.

It’s perfectly normal that a too low buffer size causes these noises. If you use higher buffer size with Asio4all they should vanish.

Regarding Ndsp releasing new plugins when these bugs are still present: I assume they have separate teams for plugins and the qc. The people working on stuff like the drivers are not the same ones working on modeling or the ones creating the UI. I get your frustration as this bug is known for quite some time but for Ndsp to stop on anything else in the meantime is not a solution to the problem

1 Like

When I say low buffer size I am talking about 128 and even at 256 I get issues. On the QC driver I get issues all the way up 1028+. Also with ASIO4All I get other problems in the recording process where it will suddenly stop for a second or so as it reaches the recording point so it’s generally unreliable. Regardless of the issues with ASIO4All, this should only be a temporary fix and it is a generic driver. Would you do serious recording with it? Probably not.

In relation to the plugins, etc. I’m sure that’s true about the teams and obviously the driver issue is specific to the QC but more broadly, from a marketing or customer satisfaction perspective it doesn’t look good for buyers of the QC when they’ve been promised all of these fixes and new stuff for the unit, money has been paid upfront for the units and for all you know they could essentially be funding the plugin platform in bringing out new plugins with that money. At the end of the day it’s still the same company and they will obviously use the same R&D for the QC as for the plugins and users should benefit from any synergies with the plugins. So separate teams or not, what happens on the plugin platform should effect what happens with the QC and vice versa. The way the plugins get such a push and QC users aren’t getting updates is frustrating to say the least. Currently you would basically be better off spending $350 on three plugins and not even own the QC.

Oh, didn’t get that, of course that’s not normal assuming you got a computer from the current century :smiley: I don’t have any problems with Asio4all. I won’t use it for anything but demo recording though and it is just a temporary workaround.

I agree that this doesn’t look too good, especially as ndsp don’t give that much updates on their progress. The qc can do everything I need it for currently, but I get that it doesn’t fit the needs of many others.

It will get better over time but for the ones who can not wait more matured devices may be the better choise.