QC frozen after 2.0 update

Hi all. Hoping this is something simple. Just updated to 2.0, all seemed ok. Did the reboot and at the end the QC reboots but then completely freezes when the first preset comes up. Nothing works, no sound, not buttons, touch screen or on / off button. The only way I can power it off is to pull the power. Is there a way to roll back to previous version?


I tried to get into the recovery screen by holding down A and H buttons, but that did not work.

OK, I unplugged my MIDI and footswitch cables, rebooted. This time it came up with a pop up box saying “finalizing 2.0 update” and now it no longer freezes! So if anyone has similar issues just unplug all of your cables and try it again.



Must be in the check sum portion. You will no doubt be helping someone who may use the search function here. Kudo’s mate.

1 Like

This is a good reminder that a best practice is to disconnect each and every cable prior to an update, including USB (unless of course there is a USB update option in the future). As of CorOS 2.0, there isn’t.

I have exactly the same problem. Just about to unplug my cables!

It worked!

Thank you so much!

Not so simple when you have everything cabled up nicely on a pedal board or racked. Also not a problem I have ever had with any other device of mine that gets updated regularly, so was not something that occurred to me straight away.

Agreed, PITA, but I have seen peripheral devices and connections cause problems with other device’s updates as well. Anything from a shorted cable to a peripheral device that manages to hang some part of the update process that is being run on one of the input/output ports on the device being updated. Shouldn’t happen but on occasion it does.

Anyway, good on ya for figuring out what caused it. Hopefully the info regarding MIDI or footswitch connections interfering with the update will save someone else some aggravation during an update. Or perhaps Neural may change whatever might have caused this in the next update.