My QuadCortex is freeze on update 2.03

CorOS: 2.0.3
My QuadCortex won’t start. I turned it on as usual today and began the update process to version 2.0.3. After downloading the software, I started the update process, but halfway through the update, the screen turned completely white. I waited for 30 minutes, but the screen appeared to be frozen.

First attempt: I unplugged the power cable and tried to restart it, but the lights keep flashing, and it won’t start.

Second attempt: I tried performing a total unit reset, but it didn’t work. After turning it off and on again, the lights flashed once more.

Third attempt: I disconnected all the cables—in, out1, out2, MIDI, and exp—and finally, it turned on. However, after 30 minutes, when I checked my backups, none of them were saved, and an error message appeared, causing it to freeze with a restart message.

I waited, but it got stuck again.

I manually restarted it again, and it presented the same problem, only flashing the lights.

Has anyone experienced the same issue? Or is there any process I can follow to restore my QuadCortex?"


Hi @ronietl , welcome and sorry to hear you are having boot up issues. You followed all the normal troubleshooting so the only thing I can add is to ensure you are using the OEM power supply? If not, ensure you are using 12v @ 3A (2A minimally). If still having issues, please email and they will get the issue logged and hopefully provide a quick resolution.

Wish you luck getting this sorted out, I’m sure you will. Your topic provided me with a couple of valuable pre-update checklist items for my next update, although neither of them was necessarily the cause of the update failing.

First, create a backup! Then disconnect all cables including expression pedal from your QC before upgrading. We have seen the expression pedal cause update problems with past firmware versions.

Use the factory power supply for the duration of the update. If you have to use an alternate, make sure it is one with specs that are equivalent. Updates can be intensive processes for devices, you don’t want yours gakking midstream because you are not providing adequate power.

1 Like

When I started the update, I was connected to my Cioks DC7 power supply. From the second attempt onwards, I connected the original power source.

1 Like

I hope my case can help mitigate future issues for other users. :slight_smile: Just so you know, the expression pedal I use is the Boss EV-30, the Morningstar MC6 Pro via MIDI, and powered by the Cioks DC7.

In the third attempt, it was connected with the original power source. After trying to restart it manually, it returned to the previous status of flashing the blue lights on the footswitches.

Continuing the saga, I conducted a few more tests. :slight_smile:

Fourth attempt: I waited for 30 minutes and managed to start it without any issues using the original power source. I performed some tests, and it is operational, although no cables are connected and I reduced the brightness of the footswitches (MIDI, IN, OUT1, OUT2, and EXP1).

Fifth step: I turned off the QuadCortex, connected all the cables (EXP1, IN, OUT1, OUT2, and MIDI), and powered it with the Cioks DC7. It has been on for 40 minutes now. Later, I will play and verify the QuadCortex’s functionality.


That is weird! Thanks for the update and very helpful diagnostics for others! Thanks and fingers crossed no more issues. I would still email support so they are aware and can log the issue(s).

My goal with this post is not to say that the QuadCortex is bad; quite the contrary. I just want to share my experience with the latest update, as the 2.0.3 version has been very unstable so far.

After contacting support, a factory restore was suggested, and that’s what I did in the sixth step.

Sixth step: I performed a factory reset and restored the second-to-last valid backup I had because I didn’t want to start my QuadCortex from scratch. While I didn’t have my backup, I noticed that it started up faster. However, after restoring the backup, I noticed that it became very slow.

I started preparing my weekend setlist, and out of nowhere, it presented the error attached below. It seems to be a software issue with the hardware, but as I’m not a QuadCortex expert, just an IT guy, I can only speculate.

I have also been reporting each step to NeuralDSP support, but so far, they haven’t identified the root cause of my problem. They only mentioned that it could be related to my Cioks DC7 power supply.

Has anyone on the forum experienced a similar problem? I haven’t found anything related to it yet.

I’m almost considering starting the QuadCortex setup from scratch, which would be terrible for me because I’ve made a lot of progress in these four months of use, and I wouldn’t want to start from zero.

Can anyone help me? Please

The only thing that jumps to mind at the moment, other than reapplying the upgrade as you already have, is the issue in 2.0.2 that prompted the quickfix version 2.0.3. I’m referring to the bug, as best I remember, where when you copied/renamed a preset in the 2.0.2 upgrade, the QC could lock up and reboot or lose the preset completely. Something akin to that. Wondering if this is potentially a problem with a preset you modified in 2.0.2. Does this happen on all presets or just specific ones? If it is preset specific, painful as it might be, I would recreate those from scratch.

I suppose another set of possibilities are that either the update still hasn’t taken properly, you have discovered a bug in 2.0.3, or that you have a hardware issue that requires repair. Wishing you luck getting this resolved with Neural support and hoping you share your resolution for the benefit of the community.

Btw, did the screenshot you included with the rebooting message happen while you were using the Cioks power supply or the one included with the QC?

The issue occurred with the Cioks DC7 power supply. I was able to replicate it only with one preset. I have sent the report when the problem occurred and I am currently awaiting a response.

Yesterday, I also noticed that one of the presets had “_1” at the end of its name in the explorer. When I accessed the preset, the “_1” didn’t show. I edited the preset to remove the “_1,” but it still appeared in the explorer. After restarting, the “_1” disappeared. Unfortunately, I couldn’t reproduce the problem and record it to send to you.

If this happens again, I will start everything from scratch.

Such issues happen in the past (with some variations) and could always happen in the future. Some may complain about the design here, but this gives also a good chance to recover from issues in an easy way.

Boot/System issues could always happen for a plenty of reasons (media error, firmware issues, software issues). My solution for a long time is a sd-card extender like this one:

This gives the opportunity to pull out the micro-sd card for a full image backup. Never had the situation of a unusable system due to issues with the Operating-System or Software after Updates.

1 Like

Sorry, no help here. I’m new to the QC.

I would love to know what are the rubber parts that you have mounted on your footswitch buttons?


Just found this amazing item on AliExpress. Check it out! R$53,91 25% Off | 10pcs Mooer SHROOMS Footswitch Toppers Candy Plastic Bumpers Electric Guitar Effects Pedal Protector

Sorry by later