QC freezes when new capture button is pressed

Just tried doing some captures of my electron analog heat. However soon as I press the new capture button the qc freezes and is completely unresponsive. I updated the firmware the other day and is first time I’d tried a capture with the new firmware. Did a few of my amp beforehand and it worked fine.
Anyone else have any issues like this, must have tried 5 times now and have to unplug it to restart it each time, power button doesn’t even work.

Also everything seems to work fine until new capture button is pressed.

Hey @Lenrod. Sorry to hear that.

Are you using CorOS 1.0.1 already? Please generate a report from your unit (Settings > Contact us > Send report) and send us a ticket to support@neuraldsp.com.


Hi, yeah using latest firmware. I’ve just tried it and it worked, well it went through to the setup screen, I don’t have time to do the whole process as about to go to work but I will try when I get home, I sent a report off the quad last night when it happened and I’ve just emailed explaining the issue. Hopefully it’s cleared.

Think I’ve figured out what could be causing it, for some reason when I have a midi cable connected to the quad midi in it doesn’t work, unplugged it and voila.