Completely frozen after sending midi TO Quad Cortex

CorOS Version: 1.1.0

Describe your issue:
When I sent quick MIDI changes over USB to my Quad Cortex from Abelton (specifically CC#1 to control a Wah effect assigned to Expression Pedal 1) the unit completely froze. There was still sound coming through, but it was stuck on whatever settings it froze in. The touchscreen was completely unresponsive as was the power button. My assumption is that the quick midi changes overwhelmed the QC?

Steps to reproduce your issue:

  1. I pulled the power plug to shut down the QC.
  2. I plugged it back in to restart.
  3. Once booted, I fiddled with the midi messages from Ableton aggressively making large/fast midi changes.

I expected this to happen:
When I changed the midi messages aggressively, I expected it to freeze again, but it didn’t no matter how fast or large the midi CC. I suppose it’s a good thing, but it’s a little worrying that it could happen during a live show and be stuck on the last setting before freezing, and require to pull the power plug.

I setup my QC to use the Quantiloop looper app from Apple app store which involved configuring the QC ‘Preset MIDI Out’ via the USB MIDI options and no issues. I was able to configure my E/F knobs for play, stop and clear with the iPhone connected etc. I haven’t tried MIDI to/from PC but so far no issues and learning the knob selections via MIDI was super easy.

I have also ran into the same freezing when using my midi keyboard with Logic Pro, however, I was only making changes within Logic and using my QC as an interface. A little different, however, still relevant that it froze with sound still active and required an restart by pulling the plug and waiting.

I tried sending a diagnostic to NDSP but it wouldn’t complete. NDSP then reached out to me and by the end of the conversation said to keep them updated if it continues or if I have new info. I haven’t tried it since.