Pitch shifter causes harmoniser like effect when listening on speakers

CorOS Version: 1.03

Describe your issue:
When I use the pitch shifter while listening via the speakers (PC speakers with subwoofer) I can clearly hear both the original and pitched sound at the same time creating a harmoniser-like effect. This is not the case when listening via the headphones (Bayerdynamic DT 770 Pro 80 ohm). It makes no difference whether I route everything via my audio interface (Audient id4 MKII) or go straight from the QC. This effect get somewhat covered up while playing rhythm parts but becomes very audible as soon as I start with my lead parts. Others in official Neural DSP Facebook QC User Group have also confirmed they experience the same behaviour.

Steps to reproduce your issue:

  1. Pitch shifter block added as first block in the signal chain
  2. Change the pitch coarse to your desired value (Mix at 100%), I would usually go 2 semitones up or down from my standard D tuning
  3. Harmoniser like effect during lead parts while listening on the speakers

I expected this to happen:
When I engage the pitch shifter and listen via the headphones (same output in my audio interface as for the speakers) the pitch change effect is perfectly working whatever I play and I can clearly hear only the pitch changed sound. I would expect for this to be case while listening via the headphones or the speakers.

I have tried the following things:

  • I have tried connecting the headphones and the speakers directly to the QC (same effect, all good on the headphones, harmoniser like effect via the spreakers)
  • I have tried using both headphones and OUT 3 or 4 outputs
  • I have tried moving the pitch shifter block in the signal chain (before or after the noise gate)
  • I have tried different speakers (please note none were proper studio monitors but others responded to my Facebook post that it’s the same story whatever speakers are used)

through headphones too!

Can you share a picture of the preset?

No other paths?

No, but frankly it makes no difference how complicated or simple the preset is.

If I am reading you correctly, when you are using your headphones you are not experiencing this issue, and your headphones are connected to the same interface as your speakers, which isn’t the QC.

Assuming this is the case, I think your problem is that when connected to speakers, you are hearing the acoustic sound of your guitar, which obviously isn’t pitch-shifted, and you aren’t hearing this when you have your headphones on (for obvious reasons).

I feel really silly now but, having tried to pick the strings very lightly, you are absolutely right. I just wasn’t expecting for the acustic sound to be still coming through with my speakers volume cranked up but it is clearly still audible. Thanks.

1 Like

I was just getting ready to tell you you are just hearing your guitar acoustically and seems like you already got it from someone else.

I’m hearing the same thing on mine. It’s mostly when I play leads or single notes where it’s most noticeable. It does it even at volumes loud enough to not hear yourself acoustically. It sounds like it’s de-tuned even though the mix is at 100% and first in the chain.

1 Like

Try to record something with pitch shift. If you only hear one pitch in the recording that’s what the QC produces.
If there’s two pitches simultaneously check your routing (pitch shifter should be the 1st in your signal and make sure it’s not in parallel something).

Thanks! I’ll give that a try.

@Foxmeister @Dawid
I got the same issue, tried on different monitors, studio, computers. (No earphone connected)
It is clearly coming from quad cortex…
Any solution ?

@Katan @Dawid @Foxmeister I am having the same issue, sounds like the mix isnt 100% and I get weird harmonizing effects both through speakers and headphones. It is particularly noticeable when playing single notes.

I hadn’t really noticed it until lately and I have used the pitch shifter pretty regularly. I wonder if it is related to my update to 1.1.0?

I’m having same issue. It is crazy out of tune. basically does what a harmoniser does only you aren’t picking thirds, 5ths, etc.

@Teatime48 For me it was definitely the acoustic sound of the strings coming from my guitar which I initially refused to believe they would be that clearly audible even with the volume of my speakers was cranked up very high. Recorded signal was absolutely fine and my headphones (Bayerdynamic DT770 Pro 80 Ohm) seemed to be blocking external noise well enough to block the acoustic sound of the plucked strings. So I only heard the problem during lead parts and while listening through the speakers. Let me know if you can hear the effect while playing single notes on your lower E string and if that is not the case then I have just solved your problem.

1 Like

There is definitely a bug here and I’m almost positive this was working in the 1.0 OS. Easy to reproduce. Setup a signal path with either Wham or Pitch Shifter and nothing else. Set the mix to 100%. You will get both Wet and Dry in the output. Tried all outputs and headphones and it appears in the recording, Easy check by going into Stomp and toggling the effect on and off. You will always get dry signal even when mix is 100%. @Dawid what version of CorOS are you on? I’m on 1.2 but had the issue on the previous version also

1 Like

Tested this and tried all pitch modules before a ton of distortion and when I record output 3-4 (wet signal) there is no trace of the original pitch whatever I do. I chose a disharmonious interval to really be able to discern the signals. I’m on CorOS 1.2.

1 Like