Petrucci Cuts out only on Distorted patches in stand alone mode

Hi I recently downloaded the Petrucci demo. I’m using it with a UAD Apollo twin X and upto date Win10
I have an issue where in stand alone mode when a heavy gain patch is selected it plays for a moment then cuts out back to clean tone , like its clipped then the plugin has stalled and needs to be re started.
Selecting clean delay and reverb based patches it run sweet and sounds amazing but when I switch back to a high gain patches it cuts out again and refuses to sit stable on anything with high gain.
I’ve read your instructions on the FAQ section about sample rate and buffer size settings and using these settings makes no difference.
I’ve updated everything there is to update from windows to the UAD Apollo and no joy.
I really wanna by this plugin but not if I cant get it to sit stable in stand alone mode.
I have not tried it as a plugin in any DAW as yet.
Anyone else have this same problem ?

Hi @sub_low ,
What are your buffer size settings on the plugin settings? I use this plugin almost daily on a 2017 MSI i-7 laptop (which is definitely not considered robust anymore) yet works flawlessly.

I’ve tried 3 different 128, 256 and 512 and all crash. Initially, I thought the larger buffer seemed more stable but then that theory went backward too and now all settings are as unpredictably stable as each other in general.

The audio quality is fine and clean etc but it crashes on any high gain patch. Ive upgraded to the latest FW on the Apollo too and no difference.

If its due to latency, you should start with a higher buffer size and work your way down until the issues occur. Alternately, have you tried to uninstall that plugin and reinstall again? Typically, latency issues will result in bit-crush type noises etc. What you are referencing is probably not due to those types of issues.
It could be a corrupted file or something else as I have never heard of a plugin crashing when using high gain etc. Have you also tried using the amp without any effects engaged? If that works, I would think it might be a resource issue with your PC. What are the specs of your PC?

Take a look at the following link:

Please contact to help you further if you are not able to resolve.