Neural QC - MIDI - Sending PC to external device


I am solving such a problem: I need my Neural DSP QC to switch via MIDI PC to
Roland GR-55.

In Program mode, I set MIDI CH=2 in MIDI (because the GR-55 works on this
channel) For each of the eight switches, I also set the MSB (1) and LSB (0)
parameters in the MIDI settings tab, because this is how it is on the GR-55.
And it should work (am I right???) that when each switch A to H is pressed, a
PG should be sent to the GR-55’s MIDI IN and it should switch to the appropriate
PG, but it doesn’t work :frowning: You don’t know me advise how to test it - break up.
I have a MIDI cable connected MIDI OUT with Neural to MIDI IN GR-55. I will
appreciate any help.

parameters intended for devices

Posielanie PC do externého zariadenia


Riešim taký problém: Potrebujem aby mi Neural DSP QC prepínal cez MIDI PC na Roland GR-55.

V Program mode som si v MIDI nastavil MIDI CH=2 (pretože GR-55 funguje na tomto kanaly) Pre každy z osmich prepínačov som si v záložke MIDI settings tiež nastavil parametre MSB (1) a LSB (0), lebo takto je to na GR-55.

A malo by to fungovať tak (hovorím správne???), že po zošliapnutí každého prepínača A až H by sa mal odoslať PG na MIDI IN GR-55 a táto by sa mala prepnúť na príslušný PG, ale nefunguje to :frowning:

Neviete mi poradiť, ako to otestovať - rozchodiť. MIDI kábel mám zapojený MIDI OUT s Neural do MIDI IN GR-55. Budem rád každej pomoci.


This might not be your problem, but QC won’t send any MIDI messages on the A…H switches unless you program the messages, there are no defaults.


But I programmed the messages - see the second image from the top of the page: Neural DSP Quad Cortex - Preset MIDI OUT - PC Roland GR-55 -

The whole sequence of what I did was as follows:

1/ Via the icon at the top right, I went to “Settings” and “MIDI settings” and set the MIDI channel to 1 (on which Neural QC communicates), I pressed Done.


3/ again via the icon at the top right, I went to the “preset MIDI out” tab and set the parameters on the default rig 11H: PC / 2 / 1 / 0 / 19 /.

PC = program change

2 = MIDI channel on which the Roland GR-55 communicates with me

1 = MSBCC0

0 = LSBCC32

19 = PC number

I pressed “Done”.

When I set the led values, the name of the rig was slanted = italics and I saved it via the SAVE icon. So I’m sure it’s written in the rig. I don’t know how else I should program it.

Or am I making a mistake somewhere?


Ale ja som tie správy naprogramoval - pozri druhý obrázok zhora na stránke: Neural DSP Quad Cortex - Preset MIDI OUT - PC Roland GR-55 -

Celý sled čo som urobil bol takto:

1/ Cez ikonu vpravo hore som som prešiel na “Settings” a ˇ"MIDI settings" a nastavil som MIDI kanál na 1 (na ktorom mi komunikuje Neural QC), stlačil som Done.

2/ nastavil som PRESET MODE

3/ opäť cez ikonu vpravo hore som som prešiel na záložku “preset MIDI out” a na predvolenom rigu 11H som nastavil parametre: PC / 2 / 1 / 0 / 19 /.

PC = program change

2 = MIDI kanál, na ktorom mi komunikuje Roland GR-55

1 = MSBCC0

0 = LSBCC32

19 = číslo PC

stlačil som “Done”.

Keď som vedené hodnoty nastavil sa názov rigu zošikmil = kurziva a cez ikonu SAVE som to uložil. Tak som v tom, že je to v rigu zapísané. Neviem ešte ako inak by som to mal naprogramovať.

Alebo robím niekde chybu?

I’m not familiar with the Roland device, but in general I always recommend using a midi monitor for debugging:

  1. Download a midi monitor (e.g. MidiView)
  2. Enable midi over usb on the QC.
  3. Connect your QC to your computer and configure the midi monitor to receive info from the QC.

Now you can see if the messages are actually being sent, and if what you read is really what you expect. Sometimes confusion comes from “first is 0” vs “first is 1” numbering conventions with respect to the hex (or actually binary) code that’s actually being sent. You can, for example, try to send the required hex code to your roland directly from your computer (e.g. from a DAW) and see if you get the expected behavior.

Ok, thanks for the tip, I’ll download it. But I think it’s wired and set up fine because when I have it controlled via an external MIDI foot controller (Microdesignum MIDI Forte 16F2D) it all works.

Ok, diky za typ, stiahnem si to. Ale myslím si, že to je zapojené a nastavené dobre, pretože keď to mám ovládané cez externý nožný MIDI ovládač (Microdesignum MIDI Forte 16F2D), tak to všetko funguje.

Great, so now you just need to compare what the midi monitor reads when you connect it to the QC vs what it reads when you connect the Forte.
My guess is that the messages will be different, which will give you an indication as to what needs to be changed in the QC settings to match the Forte.
if not, then maybe some hardware issue? I don’t know, maybe at this point I would contact support.

I downloaded the MIDI Viev program and watched the data, indeed it is transmitted up to there (even the same, although I control it through MIDI Forte). See image:

So what now? Looking for a problem in MIDI on the GR55???

Stiahol som si MIDI Viev program a sledoval data, naozaj sú dotiaľ vysielané (dokonca rovnaké, aj keď to ovládam cez MIDI Forte). Pozri obrázok:

Takže čo teraz? Hľadať problém v MIDI na GR55???

Are these the same messages you see when you connect the Forte?

One test would be setting the MIDI Channel = “OMNI” on the QC and the Roland just to eliminate the channel as a possible issue.

It seems to me as if there is MIDI data in the USB and MIDI View does not show it, but it is simply not there on the 5-DIN MIDI OUT connector. Is this also possible? Error in the firmware???

Mne to pripadá tak, ako keby MIDI data v USB boli a MIDI View icheviduje, ale na konektore 5-DIN MIDI OUT proste nie su. Je aj toto možné? CHyba v firmware???

OMNI cannot be set on the Roland GR-55, only 1 to 16 can be set in the GENERAL - PATCH CH tab.

Na Roland GR-55 nejde nastaviť OMNI, v záložke GENERAL - PATCH CH ide nastaviť len 1 až 16.

Hey, I would recommend reaching out to the support team so they can assist you.

I just looked at the GR-55’s manual and I believe you are correct. You could still set the QC to “OMNI” though. Just for long enough to test and make sure it is not a channel issue. Worth checking.

ok, i will try it… * * * ok vyskúšam to…

So much more: I connected both Neural QC and Roland GT1000core to the MIDI OUT and it works the same way - that is, when I control it via an external MIDI controller, it works and also records data in MIDI View. But when I want to control it - switch through the Nerural switches, nothing happens and there is no data on the MIDI View either (they do not arrive)

Ešte toľko: Zapojil som na MIDI OUT Neural QC aj Roland GT1000core a funguje to rovnako - to znamená, že keď to riadim cez externý MIDI ovládač, tak to funguje a aj v MIDI View data zaznamenáva. Ale keď to chcem ovládať - prepínať cez switche Neruralu, nič sa nedeje a ani data na MIDI View žiadne nie su (neprichádzajú)

Try adjusting the MIDI THRU settings- the QC is a little odd in that it doesn’t have a MIDI MERGE (yet) so in order to send MIDI currently you have to turn MIDI THRU OFF.
May not be the issue, but wanted to through it out there in case.

Roland GR-55 doesn’t have MIDI THRU, Neural QC does. On Neural QC, I set MIDI THRU to ON when I wanted to test whether the data transmission from the foot MIDI switch (OUT) to MIDI IN Neural QC and from Neural QC to the Roland GR-55 works. So you think that when I want to switch the PC switch to Neural QC, I should set QC MIDI THRU to OFF? I think I tried this option as well.

Roland GR-55 MIDI THRU nemá, Neural QC ho má. Na Neural QC som MIDI THRU nastavil na ON vtedy, keď som chel vyskúšať, či funguje prenos dát z nožného MIDI switchu (OUT) do MIDI IN Neural QC a z Neural QC do Roland GR-55. Vy teda myslíte, že keď chcem prepínať PC switchom na Neural QC, mám nastaviť na QC MIDI THRU na OFF? Myslým , že som aj túto možnosť skúšal.

Yes, I would try (again) turning MIDI THRU OFF on the QC- it will not send ANY MIDI messages unless MIDI THRU is turned OFF. The downside (which I hope is addressed in a FW update) is that it also will not pass any MIDI messages from devices earlier in the MIDI chain than the QC when MIDI THRU is disabled (there isn’t a MIDI MERGE option yet that would add any QC-originated MIDI messages along with any messages coming from devices sending MIDI to the QC). Hope that makes sense, and the rig gets working!

And this is a problem when using QC with say an MC8. I want to be able to control my Powercab212 from both QC and the MC8. For QC, I want to be able to change the Powercab patch when I change QC patch. I can do that with MIDI THRU off. But now if I want to change Powercab mode or voicing with MC8, then I need MIDI THRU (MC8 also controls QC).

But I actually think NDSP got this right. A MIDI output can’t be output and a THRU at the same time. For that, you need 3 MIDI ports: MIDI IN, OUPUT, and THRU. QC only has two, so the MIDI THRU switch changes the second port to OUTPUT or THRU, not both.

The way I use QC with Powercab112+ is to turn MIDI Thru off, and use QC patch change messages to put Powercab in the right mode - usually mode: Flat with voicing changing from LF Raw to FRFR depending on the patch. The MC8 controls QC scenes and looper. QC stays in stomp mode all the time.

Yes, when I set the Neural QC MIDI THRU to OFF, the PG send works. I was just confused that when I simultaneously connected via USB to the Roland GR-55 via the ntb MIDI View program, the DATA does not appear in this, as if it is not passing through the GR-55 USB.

Ano, keď som nastavil na Neural QC MIDI THRU na OFF, odosielanie PG funguje. Mňa len zmiatlo, že keď som mal súčasne pripojený cez USB na Roland GR-55 cez ntb program MIDI View, v tomto sa sa DATA nezobrazujú, akoby toto na GR-55 USB neprechádzalo.