Logic Pro X "incompatible" but working


I can use the cali suite in Logic Pro x 10.5, but the plugin doesn’t boot at the logic startup phase (I always get an incompatible plugin error) and is always placed in the incompatible folder for later selection. The Nolly plugin is placed in the neural dsp “logic folder” for selection. This is not a problem, but not perfect as well.


Hi @anselm.haselhoff. Have you tried reinstalling it? Make sure that iLok License Manager is up to date as well.


yes, I reinstalled it by deleting all the plugin files in the Mac OS folders (component), tried whether it is not available in logic and then started the installation process again. I have the newest version of iLok License Manager. Is there anything else I can try?


I have the same problem ever since I upgraded from High Sierra to Catalina (and Logic Pro 10.5.1)

I checked that I am running the latest version of iLok (reinstalled it as well), also tried transferring licenses around but no luck.

@anselm.haselhoff not sure if it will help you anymore but I resolved the situation by deleting some of the preferences files in my home directory. You can drop this in a file called something.command or paste it into the terminal:

mv ~/Library/Application\ Support/Neural\ DSP/Darkglass\ Ultra/Darkglass\ Ultra.settings ~/Library/Application\ Support/Neural\ DSP/Darkglass\ Ultra/Darkglass\ Ultra.settings.bak
mv ~/Library/Audio/Presets/Neural\ DSP ~/Library/Audio/Presets/Neural\ DSP.bak
mv ~/Library/Caches/com.juce.locks/juceAppLock_Darkglass\ Ultra\ ~/Library/Caches/com.juce.locks/juceAppLock_Darkglass\ Ultra.bak
mv ~/Library/Preferences/Darkglass\ Ultra.settings ~/Library/Preferences/Darkglass\ Ultra.settings.bak

Make sure Logic is closed / Darkglass plugin is not loaded in any DAW when running the above. It should not delete your old preferences in case you somehow still need them.

After moving these old files out of the way, reset and rescan in Logic.

1 Like

Oh, sorry, just realized you are using the Cali plugin but hopefully the process is similar.

This thread was the top result when I was trying to work out what was wrong with my Darkglass AU.