Inconsistencies Running QC as main interface

Hey all,

So I’ve had my QC for about a week now, I love it. I originally was using my QC into my scarlet 2i2. After reading a lot of forums I decided to just take the 2i2 out of my input chain and run the QC as my interface. Since then I’m having weird inconsistencies with my sample rate. I’m running Reaper as my main DAW but I have been able to replicate the issues in Cubase as well.

The buffer rate seems to change for no reason. For example: I’ll turn on PC open reaper and my input latency will be 2ms and my output will be 20ms. I’ll open the QC control panel and my buffer size will be 32 samples then I’ll make any change and go back to 32 where I like it and the output will go down to 2ms. Then randomly it will start getting robot’ish like the sample rate is too low. I turn it up and the same thing happens. Then say I take a break, shut down reaper then a few hours later open reaper back up and now the output latency is back at 20ms.

I’m not sure what is going on here. I’ve tried higher sample rates, lower sample rates, keeping safe mode on, keeping safe mode off. I’ve never had these issues with my scarlet as an interface, and I’ve always been able to run at 32 samples as I have a higher end PC. I don’t mind a higher sample rate with the QC as it seems to have lower latency all around.

Also, I should note I’m monitoring my project through the daw and not monitoring the QC before the daw. The reason I’m doing this is because I like to mix a bit while I track.

Any advice on this? I’m pretty stumped after a few days of this.

are you running your DAW projects at 48kHz? The QC is locked to that sample rate

Yes. It won’t even let me select a different sample rate. There is a box that says “Force Sample Rate” and allows me to type in my sample rate, should I check that box and force 48k?

As @xush indicated, the QC is locked at 48kHz so ensure your DAW is also set to 48kHz etc., I don’t believe you are running into a sample rate and or size issue as that would usually result with weird digital artifacts.

Even when I’m not in my DAW and just watching a youtube/twitch video I’ll get a weird electronic noise for a half second every know and then.

Screenshot 2023-02-16 114340

I uploaded screenshots of my session settings. This is essentially how I’ve always ran my scarlet.

After you changed the rate to 48kHz, did you close and reopen your DAW? Also ensure nothing else USB is plugged into the PC (if possible) and or remove items one at a time and see if the issue remains.

Last thought, have you tried removing the scarlet USB ASIO driver, rebooted and retested?

I’ll try that as a last resort because I still want to use it for certain things. I should be able to use both as I have more than one interface for different purposes.

I agree, it could be a compatibility issue with one of the drivers and easy enough to validate. Otherwise you can always reach out and email and they can have you send logs etc. Also, you did install the most current QC driver correct? It was updated for the 2.0 release as indicated in the release notes.

The audio driver I downloaded straight from Neural DSP site is Driver v.5.50.0

That is the latest driver installer listed on Neural’s site. You probably have the correct driver.

That is the most current drivers, so all good there.

Still having issues. Makes no sense as to what is going on. Like I’ll just be jamming away, then out of no where sound gets all jacked and I literally change the latency up one notch and back to where it was and it’s gone.

1 Like

This looks like what I have been experiencing under Linux:

But it mostly only affected the input signal.

I was trying to use the USB as an interface from my iMac desktop to the QC. When I play audio from my Apple Music or even YouTube it will start of okay and then make some weird noises and then after about 15 to 20 seconds goes all haywire and just emits strange sounds and I have to shut the music off.

In my frustration I plugged in my old MacBook Air and my new one. They both worked flawless with the USB connector with no adjustments at all. So in my case there is something weird in my iMac configuration and I may never know what it is. It has nothing to do with bitrates because the laptop can play the same ones as the Desktop that has the problem without issues.

So in my case I found a work around. IF I really need to I can use my laptop for the interface. All that being said, do you have another device to try to run things through just to see if it is like my situation? I was thinking I have a faulty QC unit, but I found out it is something on the Desktop iMac side of things. Okay, sorry for being so long winded. I do hope you are enjoying your device and I wish you peace.

download latencymon and start that and let it run for a minute and see if you get any spikes that indicate DPC problems, and hten maybe you can disable offending devices or even trying a bios update can fix with onboard devices

try disabling all onboard unused ports on your PC and disabling any other sound cards. and it can free up some resources from that pipe

1 Like