How to listen to music through the Cortex as USB interface on the Mac?

I wanted to use the Cortex to listen to music on Spotify and jam over it. I connected the USB cable to my Mac (latest OS) but I can’t get it to work.

I’m using headphones, the latest manual says I should be able to hear the computer’s audio through the headphones out (and output 1) but that’s not happening. Did I miss a step?

Hi! I‘m using the QC as an audio interface with my imac with no problems. It didn‘t like being connected via my usb hub though, so if it‘s not connected directly that might be the problem. And sometimes I have to choose it as my audio source in the audio settings if it doesn’t connect automatically. And once I had to reboot the QC for it to be recognised.

lol what an hilarious clusterfuck. I restarted the unit, and now it’s making sounds, but cycling between channels (left, then right turn off randomly) and stutters, the sound becomes metallic etc…

I would say operations as USB card simply don’t work properly at the moment.

I made a video of the issue https://www.youtube.com/watch?v=OkN6PhjJDpQ

This sounds like sample rate issues. I wonder if something is causing it to switch. If you go into Audio Midi set up on your mac, and check the QC - what is the sample rate set to? I wonder if spotify is able to play at whatever sample rate the QC is working as.

Nah, that ain’t it. If the driver doesn’t support more than one frequency, there’s no way to change it in Mac OS at the OS level, you can force it in a DAW but that’s not what’s happening here, I’m just playing Spotify.

Just to put this one to bed:

Have you by chance tried a Windows PC/latop to see if it’s a MAC specific issue?

I don’t have one unfortunately so I can’t test that.

This is probably a dumb question, but I assume your monitors are connected to OUT1/OUT2?
The symptoms are reminiscent of when was trying to get USB audio out of my desk monitors connected to OUT3/OUT4 using 1/4inch cables. Sometimes it worked, mostly it didn’t.
Just a shot in the dark in case that is your issue, too. Sorry.

I was using headphones.

I made a thread with the same/similar issue but waiting for it to be approved. I’m running a late 2014 Macbook Pro on Big Sur and find that the issue is with Coreaudiod.

The error I am getting is below and have not found a fix after trying resetting PRAM, rolling back to Catalina etc… Interestingly I’ve had no problems on a 2010 Macbook Pro running Mavericks.

HALS_IOA1Engine::EndWriting: got an error from the kernel trap, Error: 0xE00002EE

I don’t know if this helps but appears to be the same issue with core audio with some possible resolutions.

Hope it helps!

according to your uploaded picture, your audio out signal is being sent to the Scarlett interface- see the speaker icon next to it? You need to set the Cortex to be the output device as well. The Cortex has the mic icon for input, but output is going thru the Scarlett according to these settings.

I took the screenshot later to make a different point, when I tested the output was routed to the Cortex, you can see it from the video I linked, otherwise the headphones wouldn’t make any noise.