Glitch in the starred cloud presets list after downloading a preset but cancelling to choose a preset slot.

CorOS Version: 1.4

Describe your issue:
When I choose to download a starred cloud preset, then click on “choose” to choose a slot to save and then cancel the operation, it’s impossible to download and save the preset again unless I reboot the QC. In the list of starred cloud presets, the same preset then exhibits a spinning download indicator which gets overlayed by an additional download arrow.

Steps to reproduce your issue:

  1. Click on the download button of a starred cloud preset.
  2. In the saving window click on “choose” to see the banks and presets view.
  3. Click on “cancel”
  4. Try to download the same starred cloud preset again.

See video: 2022-08-11 - QC download (

I expected this to happen:
When I cancel the saving proces, I expect to be able to again download and save the same preset.

I have tried the following things:

  • I have tried refreshing the starred cloud presets lis but the spinning indicator persisted on the said preset
  • I have downloaded another preset and then checked the starred cloud presets list again but the spinning indicator persisted on the previously mentioned preset

Hi @2342 , Although it should be rare when you start to download a starred preset and then cancel for whatever reason, I would definitely reach out to to have them log the issue so that it can be resolved in the next update.

I already did. They could replicate the issue on CorOS 1.4.0 and sent it to the dev team.